U1084A User Manual

You are here: U1084A User Manual

Agilent Technologies

U1084A 8-bit High-Speed PCIe Digitizer

with on-board Signal Processing

User Manual

Introduction

This help document is intended to provide in-depth information and reference material specific to your digitizer product.

For information on getting started with your digitizer, please refer to the StartUp Guide which was delivered with your product or may be downloaded from the Agilent Technologies website.

Contents:

Notices & General Information

Description & Front Panel Connections

Channel Input

Data Acquisition

Calibration

Trigger Output

Multi-Purpose Inputs and Outputs

Digitzer with SAR Mode (-DGS Option)

Averager Mode (-AVG Option)

PeakTDC Mode (-TDC Option)

Electrical, Environmental & Physical Specifications

Programming Information

Utilities

Accessories

© Agilent Technologies, Inc. 2013. | Help version: 12 December 2013
Part No: U1084-90005 |


Notices

© Agilent Technologies, Inc. 2013

No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Agilent Technologies, Inc. as governed by United States and international copyright laws.

Manual Part Number

U1084-90005

Support

To contact Agilent for sales and technical support, refer to the “support” links on the following Agilent web resources:

www.agilent.com/find/Digitizers - Home page for the entire range of Agilent modular digitizer products.

www.agilent.com/find/assist - Worldwide contact information for repair and service.

www.agilent.com/find/tips - Information on preventing damage to your Agilent equipment.

Regulatory Compliance

This product has been designed and tested in accordance with accepted industry standards, and has been supplied in a safe condition. To review the Declaration of Conformity, go to http:/regulations.corporate.agilent.com/DoC/search.htm.

Warranty

The material contained in this document is provided “as is,” and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information

contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Technology Licenses

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

Restricted Rights Legend

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as “Commercial computer software” as defined in DFAR 252.227-7014 (June 1995), or as a “commercial item” as defined in FAR 2.101(a) or as “Restricted computer software” as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

Conventions Used in this Document

The following convetions are used in this document:

A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.

A Caution notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met

This is a note, drawing the reader's attention to important information, caveats, etc.

'Italic' text denotes a reference to a quoted name or entity. e.g."Press the 'Run' button."

Bold Italic text is used to emphasize an important action point in the text. e.g. "Open the View menu and select the All option."

mono text is used for sections of code, programming examples and operating system commands. e.g. "Type the command >> Run -all"

Underlined Italic text denotes paths or file names. e.g. "The file is located in the folder, e.g...\Agilent\MD1\.."

Safety Notices

The following safety precautions should be observed before using this product and any associated instrumentation.

This product is intended for use by qualified personnel who recognize shock hazards and are familiar with the safety precautions required to avoid possible injury. Read and follow all installation, operation, and maintenance information carefully before using the product.

If this product is not used as specified, the protection provided by the equipment could be impaired. This product must be used in a normal condition (in which all means for protection are intact) only.

The types of product users are:

  • Responsible body is the individual or group responsible for the use and maintenance of equipment, for ensuring that the equipment is operated within its specifications and operating limits, and for ensuring operators are adequately trained.
  • Operators use the product for its intended function. They must be trained in electrical safety procedures and proper use of the instrument. They must be protected from electric shock and contact with hazardous live circuits.
  • Maintenance personnel perform routine procedures on the product to keep it operating properly (for example, setting the line voltage or replacing consumable materials). Maintenance procedures are described in the user documentation. The procedures explicitly state if the operator may perform them. Otherwise, they should be performed only by service personnel.
  • Service personnel are trained to work on live circuits, perform safe installations, and repair products. Only properly trained service personnel may perform installation and service procedures.

Agilent products are designed for use with electrical signals that are rated Measurement Category I and Measurement Category II, as described in the International Electrotechnical Commission (IEC) Standard IEC 60664. Most measurement, control, and data I/O signals are Measurement Category I and must not be directly connected to mains voltage or to voltage sources with high transient over-voltages. Measurement Category II connections require protection for high transient over-voltages often associated with local AC mains connections. Assume all measurement, control, and data I/O connections are for connection to Category I sources unless otherwise marked or described in the user documentation.

Exercise extreme caution when a shock hazard is present. Lethal voltage may be present on cable connector jacks or test fixtures. The American National Standards Institute (ANSI) states that a shock hazard exists when voltage levels greater than 30 VRMS, 42.4 V peak, or 60 VDC are present. A good safety practice is to expect that hazardous voltage is present in any unknown circuit before measuring.

Operators of this product must be protected from electric shock at all times. The responsible body must ensure that operators are prevented access and/or insulated from every connection point. In some cases, connections must be exposed to potential human contact. Product operators in these circumstances must be trained to protect themselves from the risk of electric shock. If the circuit is capable of operating at or above 1000 V, no conductive part of the circuit may be exposed.

Do not connect switching cards directly to unlimited power circuits. They are intended to be used with impedance-limited sources. NEVER connect switching cards directly to AC mains. When connecting sources to switching cards, install protective devices to limit fault current and voltage to the card.

Before operating an instrument, ensure that the line cord is connected to a properly-grounded power receptacle. Inspect the connecting cables, test leads, and jumpers for possible wear, cracks, or breaks before each use.

When installing equipment where access to the main power cord is restricted, such as rack mounting, a separate main input power disconnect device must be provided in close proximity to the equipment and within easy reach of the operator.

For maximum safety, do not touch the product, test cables, or any other instruments while power is applied to the circuit under test. ALWAYS remove power from the entire test system and discharge any capacitors before: connecting or disconnecting cables or jumpers, installing or removing switching cards, or making internal changes, such as installing or removing jumpers.

Do not touch any object that could provide a current path to the common side of the circuit under test or power line (earth) ground. Always make measurements with dry hands while standing on a dry, insulated surface capable of withstanding the voltage being measured.

The instrument and accessories must be used in accordance with its specifications and operating instructions, or the safety of the equipment may be impaired.

Do not exceed the maximum signal levels of the instruments and accessories, as defined in the specifications and operating information, and as shown on the instrument or test fixture panels, or switching card.

When fuses are used in a product, replace with the same type and rating for continued protection against fire hazard.

Chassis connections must only be used as shield connections for measuring circuits, NOT as safety earth ground connections.

If you are using a test fixture, keep the lid closed while power is applied to the device under test. Safe operation requires the use of a lid interlock.

Instrumentation and accessories shall not be connected to humans.

Before performing any maintenance, disconnect the line cord and all test cables.

To maintain protection from electric shock and fire, replacement components in mains circuits – including the power transformer, test leads, and input jacks – must be purchased from Agilent. Standard fuses with applicable national safety approvals may be used if the rating and type are the same. Other components that are not safety-related may be purchased from other suppliers as long as they are equivalent to the original component (note that selected parts should be purchased only through Agilent to maintain accuracy and functionality of the product). If you are unsure about the applicability of a replacement component, call an Agilent office for information.

No operator serviceable parts inside. Refer servicing to qualified personnel. To prevent electrical shock do not remove covers. For continued protection against fire hazard, replace fuse with same type and rating.

Front and Rear Panel Symbols:

The CE mark is a registered trademark of the European Community.

The C-Tick mark is a registered trademark of the Australian Spectrum Management Agency.

This symbol indicates product compliance with the Canadian Interference-Causing Equipment Standard (ICES-001). It also identifies the product is an Industrial Scientific and Medical Group 1 Class A product (CISPR 11, Clause 4).

South Korean Class A EMC Declaration. this equipment is Class A suitable for professional use and is for use in electromagnetic environments outside of the home.

A 급 기기 ( 업무용 방송통신기자재 ) 이 기기는 업무용 (A 급 ) 전자파적합기기로서 판 매자 또는 사용자는 이 점을 주 의하시기 바라 며 , 가정외의 지역에서 사용하는 것을 목적으 로 합니다 .

This symbol indicates separate collection for electrical and electronic equipment, mandated under EU law as of August 13, 2005. All electric and electronic equipment are required to be separated from normal waste for disposal (Reference WEEE Directive, 2002/96/EC).

This symbol on an instrument means caution, risk of danger. You should refer to the operating instructions located in the user documentation in all cases where the symbol is marked on the instrument.

This symbol indicates the time period during which no hazardous or toxic substance elements are expected to leak or deteriorate during normal use. Forty years is the expected useful life of the product.

ESD Sensitive Device

This symbol indicates the instrument is sensitive to electrostatic discharge (ESD). ESD can damage the highly sensitive components in your instrument. ESD damage is most likely to occur as the module is being installed or when cables are connected or disconnected. Protect the circuits from ESD damage by wearing a grounding strap that provides a high resistance path to ground. Alternatively, ground yourself to discharge any built-up static charge by touching the outer shell of any grounded instrument chassis before touching the port connectors.

This symbol denotes a hot surface. The side cover of the module will be hot after use and should be allowed to cool for several minutes.

Cleaning Precautions:

To prevent electrical shock, disconnect the Agilent Technologies instrument from mains before cleaning. Use a dry cloth or one slightly dampened with water to clean the external case parts. Do not attempt to clean internally. To clean the connectors, use alcohol in a well-ventilated area. Allow all residual alcohol moisture to evaporate, and the fumes to dissipate prior to energizing the instrument.

Definitions for specifications

Specifications describe the warranted performance of calibrated instruments that have been stored for a minimum of 2 hours within the operating temperature range of 0 to 45 °C, unless otherwise stated, and after a 45 minute warm-up period. Data represented in this document are not specifications unless otherwise noted.

Characteristics describe product performance that is useful in the application of the product, but that is not covered by the product warranty. Characteristics are often referred to as Typical or Nominal values.

  • Typical describes characteristic performance, which 80% of instruments will meet when operated over a 20 to 30 °C temperature range. Typical performance is not warranted.
  • Nominal describes representative performance that is useful in the application of the product when operated over a 20 to 30 °C temperature range. Nominal performance is not warranted.


TIP: Help Search Techniques

You are here: U1084A User Manual > Notices & General Information > TIP: Help Search Techniques

TIP: Help Search Tricks

In the help system, a basic search of topics consists of the word or phrase that you want to find. You can, however, improve your search results by using wildcard expressions, nested expressions, Boolean operators, and searching similar word matches, previous results, and topic titles only.

Performing a Basic Full-Text Search

  1. In the navigation pane, click the Search tab and then type the word or phrase that you want to find. Use the right-arrow button to add Boolean operators to your search.
  • Click List Topics.Your search will return the first 500 hits. If you want to sort the topic list, click Title, Location, or Rank.
  • Highlight the topic that you want, and then click Display You can also display any topic by double-clicking it.

Refining a Your Search

You can refine a basic search by using wildcard expressions, nested expressions, and Boolean operators. You can also search only on the previous results list, request similar word matches, or search only the titles of topics in the table of contents.

  • To refine a search to include just the last group of topics you searched, select the Search previous results check box.
  • To match similar spellings in a full-text search, select the Match similar words check box.

When Match similar words is selected, the viewer matches minor grammatical variations of the word or phrase you entered, as well as the word or phrase itself. For example, if you entered "test" and selected this box, the Library viewer would find "test", "tests", and "testing". This option is independent of other options or syntax. If you do a titles-only search, variations in titles will be matched. If you use quotes (or any other query operator) any variation of the word can appear; for example, "installed module" will also match "installing module".

  • To search for words in document titles only, select the Search titles only check box.

Search Syntax

The basic rules for formulating queries are as follows:

  • Searches are not case-sensitive, so you can type your search in uppercase or lowercase characters.
  • You can search for any combination of letters (a–z) and numbers (0–9). You cannot search for single letters (a, b, c, etc.) and the following reserved words: an, and, as, at, be, but, by, do, for, from, have, he, in, it, not, of, on, or, she, that, the, there, they, this, to, we, which, with, you.
  • Punctuation marks such as the period (.), colon (:), semicolon (;), comma (,), and hyphen (-) are ignored during a search.
  • Group the elements of your search using "double quotes" or (parentheses). You cannot search for quotation marks.

If you are searching for a filename with an extension, you should group the entire string in double quotes ("filename.ext"). Otherwise, the search will treat the period as an OR operator.

Words, Phrases, and Wildcards

You can search for words or phrases and use wildcard expressions. The table below describes the results of these different kinds of searches.

Search for | Example | Results
Single word | Calibrate | Topics that contain the word "calibrate." (You will also find its grammatical variations, such as "calibration" and"calibrated".)
Phrase | "saved configuration" -or- 'saved configuration' | Topics that contain the literal phrase "saved configuration" and all its grammatical variations. Without the quotation marks, the query is equivalent to specifying a saved AND configuration, which will find topics containing both of the individual words, instead of the phrase.
Wildcard expressions | Meas* | Topics that contain the terms "Meas," "measure," "measurement," and so on. The asterisk cannot be the only character in the words.
 | 89?00 | Topics that contain the terms "89500," "89600," "89700," and so on. The question mark cannot be the only character in the term.
 | *936* | Topics that contain the terms "936." "45936,""M9360A," "93600" and so on.
 | *93 | Topics that contain the terms "293," "393," "x93," "ABCD393," "8093," and so on.

Operators: AND, OR, NOT, and NEAR

The AND, OR, NOT, and NEAR operators allow you to refine your search. The following table shows how to use each of these operators.

Search for | Example | Results
Both terms in the same topic | performance AND verification -or- performance & verification | Topics containing both the words "performance" and "verification."
Either term in a topic | front OR panel -or- front | panel | Topics containing either the word "front" or the word "panel."
The first term without the second term | system NOT requirements -or_ system ! requirements | Topics containing the word "system," but not the word "requirements."
Both terms in the same topic, close together | install NEAR hardware | Topics containing the word "install" within eight words of the word "hardware."

Rules for Nested Expressions

The basic rules for searching topics using nested expressions are as follows:

  • You can use parentheses to nest expressions within a query. The expressions in parentheses are evaluated before the rest of the query.
  • If a query does not contain a nested expression, it is evaluated from left to right. For example, "Instrument NOT system OR calibration" finds topics containing the term "instrument" without the term "system", or topics containing the term "instrument" and not "calibration". (On the other hand, "instrument NOT (system OR calibration)" finds topics containing the term "instrument" without either of the terms "system" or "calibration".)
  • Nesting allows you to create more complex search expressions. For example, "instrument AND ((system OR calibration) NEAR performance)" finds topics containing the term "instrument" along with the terms "system" and "performance" close together, or containing "instrument" along with the terms "calibration" and "performance" close together.
  • You cannot nest expressions more than five levels deep.


FAQs

Q. What is Coherent Sampling

A. Coherent Sampling refers to the relationship between the input frequency, sampling frequency, number of cycles in the sampled set and the number of samples. With coherent sampling one is assured that the signal power in an FFT is contained within one FFT bin (assuming a single input tone).

The condition for coherent sampling is given by:

For example if we have Msamples = 211, and fs = 100e6, and we expect and input frequency close to fs/2, let's say fin = 44 MHz,

Then Ncycles = 901.12 which is close to an integer. We could therefore round down to Ncycles = 901 and we would get fin = 43.994140625 Mhz, which is an input frequency that satisfies coherent sampling.

The integer number should be chosen carefully. We have three possible types of integers, even, odd, and prime. Even is not a good idea since we would hit the same code every Msamples, where M can be much less than N. Odd is a better idea since it takes longer to hit the same code. According to some sources a prime number of cycles is the best (with the exception of the prime 2) because it takes a long time before the same code repeats.


Related Documentation

Documentation Access Map

All documentation relating to your Agilent Technologies digitizer may be found either from the CDROM supplied with your product, or from the Agilent website as shown in the diagram below:

Documentation

If you have run the Agilent MD1 software installer for your product on your PC, the related product documentation will have been installed to your hard drive. Otherwise these documents are available for download from the Agilent Technologies website

Document

Startup Guide

Includes procedures to help you to unpack, inspect, install (software and hardware), perform instrument connections, verify operation, and troubleshoot your product. Also includes an annotated block diagram.
User Manual

Provides in-depth information and reference material specific to your digitizer product
Data Sheet

In addition to a detailed product introduction, the data sheet supplies full product specifications.
Soft Front Panel (help system)

Provides information on the use of the Soft Front Panel for MD1 digitizers.
LabVIEW Driver reference (help system)

Provides detailed documentation of the LabVIEW G driver API functions.
IVI Driver reference (help system)

Provides detailed documentation of the IVI-COM and IVI-C driver API functions, as well as information to help you get started with using the IVI drivers in your application development environment.


Full Product Family Listing & Cross-reference tables

This help file has been organized to allow easy access by arranging the product lines under their form factors listed below:

PXI Express High-Speed Digitizers

This product line is composed of Agilent PXI Express new generation of high-speed digitizers.

These are PXI Express compliant, using either a PXIe or PXIe Hybrid slot. Designed to benefit from fast data interfaces, the products can be integrated with other test and automation modules in PXIe and Hybrid chassis slots. The PXI format offers high performance in a small, rugged package. It is an ideal deployment platform for many automated test systems

Agilent Model Number | Model Name
M9202A | PXI Express 12-bit Wideband IF Digitizer
U5203A | PXI Express 12-bit High-Speed Digitizer
PXI Hybrid High-Speed Digitizers

This product line is composed of Agilent PXI Hybrid high-speed digitizers.

These are PXI compliant digitizers, using either a cPCI (J/J2), PXI-1 or PXIe Hybrid slot. The PXI format offers high performance in a small, rugged package. It is an ideal deployment platform for many automated test systems.

Agilent Model Number | Model Name
M9210A | 10-bit Digitizing Scope
M9211A | 10-bit UWB IF Digitizer
AXIe Digitizers

This product line is composed of Agilent Technologies new generation of AXIe Digitizers.

The AXIe format offers high performance in a highly scalable package, offering at least twice the channel density of currently available comparable solutions. Making it ideally suited to large scale experiments in applied physics, such as particle physics, nuclear fusion, hydrodynamics or microwave radio astronomy.

Agilent Model Number | Model Name
M9703A | AXIe 12-bit Wideband Digitizer
U10xx - PCI / PCI Express / CompactPCI / VME Products

Agilent Technologies Inc. acquired Acqiris SA and its product lines in December 2006. Use the tables below to cross reference the Acqiris model name with the newer Agilent model numbers.

8 bit Digitizer Products
Agilent Model Number | Acqiris Model Name
U1061A-001-F50 | DC135
U1061A-001-FHZ | DC135HZ
U1061A-002-F50 | DC140
U1061A-002-FHZ | DC140HZ
U1063A-001 | DC265
U1063A-002 | DC270
U1064A-001-F50 | DC211
U1064A-001-FHZ | DC211A
U1064A-002-F50 | DC241
U1064A-002-FHZ | DC241A
U1064A-004-F50 | DC271
U1064A-004-FHZ | DC271A
U1067A-001 | DP105
U1067A-002 | DP110
U1068A-001 | DP210
U1068A-002 | DP211
U1069A-001 | DP214
U1069A-002 | DP235
U1069A-003 | DP240
U1071A-001 | DP1400
U1071A-001-F50 | DP1400
U1071A-001-FHZ | U1071AHZ1
U1071A-002-F50 | U1071A002
U1071A-002-FHZ | U1071AHZ2
U1071A-004-F50 | U1071A004
U1071A-004-FHZ | U1071AHZ4
U1084A | -
U1091AC10 | DC110
U1091AD06/07 | DP106
U1091A-003 | DP212
10 bit Digitizer Products
Agilent Model Number | Acqiris Model Name
U1062A-001 | DC122
U1062A-002-2F5 | DC152
U1062A-002-2FZ | DC152HZ
U1065A-001-FHF | DC222HF
U1065A-001-F50 | DC222
U1065A-002-F50 | DC252
U1065A-002-FHF | DC252HF
U1065A-004-F50 | DC282
U1065A-004-FHZ | DC282HZ
12 bit Digitizer Products
Agilent Model Number | Acqiris Model Name
n/a | DC436
U1066A-002 | DC438
U1066A-001 | DC440
U1070A-003 | DP306
U1070A-002 | DP308
U1070A-001 | DP310
Analyzers and Averagers
Agilent Model Number | Acqiris Model Name
U1080A-001 | AC240
U1080A-002 | SC240
U1081A-001 | AP100
U1081A-002 | AP101
U1081A-003 | AP200
U1081A-004 | AP201
U1082A-001 | AP240
U1082A-002 | AP235
U1091AAC1 | AC210
U1091ASC1 | SC210


Agilent U1084A - Overview

The U1084A series Digitizers are PCI Express modules that plug directly into any vacant long PCIe slot in a PC. They are fully programmable over the PCIe bus and deliver 4 GS/s real-time performance. With 2 signals channels offering analog bandwidths of 1.5 GHz (Typical 1.8 GHz) that can analyze at sampling rates up to 4 GS/s. Data can be transferred to a host processor over the PCIe bus at speeds up to 520 MB/s.

For complete technical specifications concerning your particular digitizer please refer to the product’s Specifications & Characteristics contained in the U1084A Brochure. Up-to-date versions of all product data sheets on our web site (http://www.agilent.com/find/U1084A). The data sheets are available in pdf format and are best viewed using Adobe Acrobat software. If you have trouble accessing our web site, or viewing the data sheets, please contact your nearest sales office.

Key Features

High Speed and Precision

The U1084A provides both an ultra-fast real-time acquisition capability and exceptionally high data transfer rates to the host processor.The two-channel U1084A delivers a real-time sampling rate of up to 2 GS/s with 1.5 GHz of analog bandwidth simultaneously on both channels. Alternatively it can be used as a one channel instruments with double the sampling rate. The high sampling rate is achieved in real time for each trigger and does not require the use of interleaved sampling techniques.

Signal conditioning

The U1084A models include all the required input signal conditioning such as gain, from 50 mV to 5 V Full Scale, offset adjustment and 50 Ω DC coupling. The inputs are fully protected, and internal calibration is a built-in feature. A crystal controlled time base and advanced trigger circuits are used to allow fast and stable acquisitions.

Firmware Options / Switching

The U1084A digitizer may be purchased in a number of different configuration options as shown in the table below. This user manual describes the standard digitizer (-DGT) option, with the extended modes being described in separate sections shown. Any specifications shown in the main body of this manual apply to the -DGT version.

Note: Firmware switching is not supported under Linux operating systems.

The available firmware options are:

  • -DGT : Standard digitizer firmware with long acquisition memory.
  • -DGS : Digitizer firmware with SAR functionality. See U1084A-DGS Digitizer with SAR Mode
  • -AVG : Real-time sampling and averaging firmware. See U1084A-AVG Averager Mode
  • -TDC : Real-time signal peak detection and Time-to-Digital Conversion and analysis firmware. See U1084A-TDC Peak TDC Mode
Orderable options | Firmware Switching
-DGT | -
-DGT / -DGS | -
-DGT / -AVG | Digitizer ↔ Averager
-DGT / -DGS / -AVG | Digitizer ↔ Averager
-DGT / -TDC | Digitizer ↔ PeakTDC
-DGT / -DGS / -TDC | Digitizer ↔ PeakTDC
-AVG / -TDC | Averager ↔ PeakTDC
-AVG | -
-TDC | -

The U1084A features the ability to store two of these firmware options at the same time, and allows the user to switch between these operating modes whilst running the digitizer. The U1084A features two EEPROM memories (EEPROM0, EEPROM1).

If both EEPROM locations contain firmware, then the user may switch between them either by using the SFP or with the driver command AcqrsD1_configMode (see the Programmers Guide / Programmers Reference for more details).

Switching is permitted between any two of the three possible firmware options that are loaded. For more information on how to load firmware into the EEPROM memory please refer to Upgrading your Modules Firmware.

An internal calibration is required after each firmware switch.
It is important to note that during firmware switching the FPGA automatically removes power from acquisition circuit for a very short time. This sequence induces some signal drift in the front-end during that period. This drift may vary from one module to another. It is therefore recommended after each firmware switch, to wait at least 10 seconds then perform a self-calibration operation. This 10 second delay allows the module to reach its normal working condition and be within 1% measurement precision. Note, that this 10 s delay is automatically included during the normal start-up & calibration sequence of the digitizer.

Front Panel Connections

The front panel connections for the U1084A are shown below. For specific information on the input/output characteristics of a particular model please refer to the sub-sections which are linked in the table.

Front Panel Connectors

Connector | Type | Description
TR IN | MCX female | External trigger input, see the Trigger section.
CLK IN | MCX female | The external clock signal input, see the External Clock and Reference section.
INPUT 1, 2 | BNC female | The analog signal input, see the Channel Input Specifications section.
TR OUT | MCX female | A trigger signal output, see the Trigger Output section.
I/O A, B, C | MCX female | Configurable multi-purpose input/output signals, see the Multi-Purpose Inputs and Outputs section.

STATUS LED

LED State | Description
 | Power is not present or the module has a fault.
 | Indicates that the trigger is armed and waiting for a valid trigger to occur.
 | Indicates that a trigger has occurred, and the acquisition is complete.


Channel Input Specifications

This section provides information and specifications regarding the input characteristics of the digitizer.

Model Number | Chan | Coupling | Impedance | Bandwidth guaranteed (typical) | Risetime | BW Limiter selections | FS Voltage ranges | Maximum Signal | Maximum Offset
U1084A-001 | 2 | AC, DC | 50 Ω | 1.5 GHz | 230 ps | 20, 200, 700 MHz | 0.05 – 5 V | ±5 V | ±2 V (<1 V FS) ±5 V (1-5 V FS)
U1084A-002 | 2 | AC, DC | 50 Ω | 1.5 GHz | 230 ps | 20, 200, 700 MHz | 0.05 – 5 V | ±5 V | ±2 V (<1 V FS) ±5 V (1-5 V FS)
U1084A-003 | 2 | AC, DC | 50 Ω | 500 MHz |  | 20, 200 MHz | 0.05 – 5 V | ±5 V | ±2 V (<1 V FS) ±5 V (1-5 V FS)

Coupling

Both AC and DC coupling modes are available. DC mode allows the full signal bandwidth to be passed through to the digitizer, whereas the AC mode couples signals capacitively thus removing the input signal’s DC component and filtering out any signal component below the cut-off frequency:

Impedance

The 50 Ω coupling mode offers high quality termination with better than ± 1% precision. It is ideally suited to use with 50 Ω transmission lines (coax), high bandwidth low impedance (typically 500 Ω) probes, or active probes.

For extreme cases, such as detector sparking, an external coaxial spark gap and attenuator (U1092-HVB) can be supplied on request.See U1092A-HVB XA100 BNC Input Over-voltage Protection

Input Protection

The input amplifiers are fully protected against overvoltage signals. The device is built to tolerate the following without damage to the front-end electronics:

  • IEC61000-4-2 (ESD): ± 15 KV (air/contact)
  • IEC61000-4-4 (EPT): 40 A (5/50 ns)
  • IEC61000-4-5 (surge): 5 A (8/20 µs)

For extreme cases, such as detector sparking, an external coaxial spark gap and attenuator (U1092-HVB) can be supplied on request. U1092A-HVB XA100 BNC Input Over-voltage Protection

Bandwidth and Rise Time

The bandwidth specification indicates the frequency at which an input signal will be attenuated by 3 dB (approximately 30% loss of amplitude).

The bandwidth also affects the minimum rise and fall times that can be passed through the front-end electronics. A pulse with a very sharp edge will be observed to have a minimum rise time (τmin) determined by the front-end electronics. In general a pulse with a given 10-90% rise time (τ10-90real) will be observed with a slower value given by:

The table above indicates the bandwidth and rise time performance. For many digitizers, the bandwidth can be limited with hardware bandwidth limiters as shown in the tables below. For many of the older models the bandwidth at 50 mV FS, BW50, is not as high as that of the other sensitivities.

Input Voltage and Offset

The input channel provides a fully programmable amplifier with variable input voltage and offset.

Full Scale (FS) input voltages are selectable as shown in the table above in a 1, 2, 5 sequence. Care should be taken to select an input voltage range that will allow the signal to be recorded using as much dynamic range of the digitizer as possible. Signals going outside of the FS Range will be clipped and data values for the clipped portion of a signal should be regarded as erroneous

The Variable Offset is programmable in the range of ±2 V when using an FS Input Voltage setting of 500 mV or below, increasing to ± Maximum Offset for FS settings above 500 mV (see the preceding table).

The raw 8-bit ADC data values are in the range [-128, +127] with the first and last values reserved for underflow and overflow respectively.

The midpoint value, 0, of the range corresponds to the negative of the offset voltage. Thus the Full Scale Range (FSR) goes from:

-Offset Voltage - (FS/2) to -Offset Voltage + (FS/2)

Signals going outside of the FSR will be clipped and data values for the clipped portion of a signal should be regarded as erroneous.

Vertical Resolution

The digitizers described in this manual use an ADC system with 8 bits of vertical resolution (256 levels). The dynamic range of the ADC covers the Full Scale Range (FSR) of the Input Voltage setting. For example, if the Input Voltage is set to 1 V then the ADC resolution is equivalent to 3.91 mV. To obtain the best dynamic range from the ADC care should be taken to ensure that the input signal varies over more than 50% of the Input Voltage FSR setting.

Linearity and Dithering

For raw ADC values the differential linearity is better than ±0.9 LSB. In the Averaging mode, an offset dither of up to ± 12 ADC codes can be added to the input signal. This dithering improves the Accumulation’s differential and integral non-linearity and can reduce quantization non-linearity errors for low noise signals

The dithering range is selectable and has a resolution of ⅛ of the ADC Least Significant Bit (LSB). The dithering is added as a controlled offset at the input of the ADC. The offset amount is different for each successive acquisition of a waveform. The offset sequence is

0, -⅛, ⅛, -2/8, 2/8, -⅜, ⅜, , . . . - (N-⅛), (N-⅛), -N, N, 0, -⅛, ⅛, etc

N is programmable between 0 (no dithering) and 15. There are 16*N+1 states in the complete cycle. Underflow/overflow conditions must be avoided.

Using Probes

The 50 Ω setting is most commonly used for active probes and low impedance (500 Ω) passive probes. Before using any passive probe with a digitizer care should be taken to check that the probe has been correctly adjusted (refer to the Probe’s Calibration procedure).


Data Acquisition

The table below summarizes the data acquisition characteristics for all models, and are further described below.

Model | Maximum Sampling Rate | No Channels | Combined mode | Default Memory(S/ch.) | Maximum Optional Memory (S/ch.) | Maximum Segments | TTI Resolution | Timebase Accuracy | External Clock Min/Max Thresh. | Minimum Deadtime
U1084A-001 | 2-4 GS/s | 2 | Yes | - | - | - | 15 ps | 2 ppm | ± 2 V | < 1.8 us
U1084A-002 | 1-2 GS/s |  |  | - | - | -
U1084A-003 | 0.5-1 GS/s |  |  | - | - | -
-STD | - |  |  | 256 M | 256 M | 131000
-256 | - |  |  | 128 M | 256 M | 65500
-128 | - |  |  | 64 M | 256 M | 32750

Sampling Rate

The U1084A Digitizers include an analog-to-digital converter (ADC) that can sample waveforms in real time, at rates from 2 GS/s (0.5 ns per point) down to 488.28 kS/s (~2 µs per point) in binary steps. The data of all of the active channels is acquired synchronously; all of the ADC’s are acquiring data at the same time, to within a small fraction of the maximum sampling rate. Alternatively, the digitizer can be run in a single-channel mode with sampling rates up to 4 GS/s.

Trigger Time Calibration

The trigger position is dynamically calibrated each time the sample rate changes from 4GS/s to 2GS/s or less, or back to 4GS/s when the module is configured as a single channel module.

The trigger position is also dynamically calibrated each time the sample rate changes from 2GS/s to 1GS/s or less, or back to 2GS/s when the module is configured as a single channel module.

Acquisition Memory

Data from the ADC is stored in on-board acquisition memory. The amount of memory in use for acquisition can be programmed and is selectable from 1 point to the full amount of acquisition memory available.

For technical reasons, a certain memory “overhead” is required for each waveform, reducing the available memory by a small amount. In order to simplify programming, an interface function recommends the best sampling rate and the maximum possible number of data points, taking into account the available memory, the requested time window, the number of segments (in Sequence mode), as well as the required memory overhead.

To ensure maximum sampling rate and high timing resolution, we strongly recommend the use of long acquisition memories whenever possible.

For example, a digitizer with 2 Mpoints of memory can record a signal over a 2 ms period with a sampling rate of 1 GS/s (1 ns per point). The fast sampling rate ensures that all high frequency signal components, up to the full bandwidth of the digitizer, are accurately recorded. If the memory were reduced to just 20 Kpoints then the sampling rate would need to be reduced to just 10 MS/s (20,000/2 ms) to record the same 2 ms period. All frequencies above 5 MHz would then be incorrectly digitized and important signal characteristics may be distorted or even completely missed.

Single and Sequence Acquisition Modes

Digitizers acquire waveforms in association with triggers. Each waveform is made of a series of measured voltage values (sample points) that are made by the ADC at a uniform clock rate. Time differences up to 213 days can be measured. The TTI resolution sets the resolution of the trigger time stamps. To maximize sampling rates and utilize memory as efficiently as possible, the digitizers include both Single and Sequential storage modes. For both of these modes the data of all of the active channels is acquired synchronously; all of the ADC’s are acquiring data at the same time, to within a small fraction of the maximum sampling rate.

The Single Acquisition mode is the normal operation of most digitizer products. In this mode an acquisition consists of a waveform recorded with a single trigger. The user selects the sampling rate and acquisition memory size and sets the number of segments to 1 (default value).

The Sequence Acquisition mode allows the capture and storage of consecutive “single” waveforms. In the API, the term 'MultiRecord' is used for 'Sequence' and 'Record; is used for 'Segment'. Sequence Acquisition mode is useful as it can optimize the digitizer’s sampling rate and memory requirements for applications where only portions of the signal being analyzed are important. The mode is extremely useful in almost all impulse-response type applications (RADAR, SONAR, LIDAR, Time-of-Flight, Ultrasonics, Medical and Biomedical Research, etc.).

In Sequence Acquisition mode the acquisition memory is divided into a pre-selected number of segments. Waveforms are stored in successive memory segments as they arrive. Each waveform requires its own individual trigger. Sequence acquisition enables successive events, which can occur within a very short time, to be captured and stored without loss.

The memory can be divided into any number of segments up to that models maximum (refer to the table above). In Sequence Acquisition mode the user needs to specify the sampling rate, the total acquisition memory, and the number of segments. Note that the Single Acquisition mode is just a special case of the Sequence Acquisition mode with the number of segments set to 1.

A crucial feature of Sequence Acquisition mode is that it has a very fast trigger rearm time. A fast trigger rearm helps produce very low “dead time” between the segments of a sequence acquisition. The “dead time” is the period after the end of an event when the card cannot digitize data for a new trigger event. To complement this mode of operation the digitizer can also measure and store the arrival time of each trigger using the information from the on board Trigger Time Interpolator (TTI). Readout of the individual trigger time stamps makes it possible to determine the time from one trigger to any other trigger in the sequential acquisition. The TTI resolution sets the resolution of the trigger time stamps (see the table above).

Timing

A crystal-controlled timebase is used to provide the clock to the ADCs. The timebase accuracy is guaranteed as shown in the table at the beginning of this section. The digitizers also include a built-in Trigger Time Interpolator (TTI) that measures the time from the trigger point to the first sample point. This information is essential for determining the precise relation between the trigger or other event of interest and the digitized samples of the signal. The approximate TTI resolution is also given in the table at the beginning of this section.

Timebase Range

The timebase range defines the time period over which data is being acquired. For example, if a digitizer has a standard acquisition memory of 256 Kpoints and maximum sampling rate of 2 GS/s, then at the maximum sampling rate, the digitizer can record a signal over a timebase range of up to 130 µs (approx. 260,000 points * 0.5 ns/point). The timebase range can be adjusted by varying the amount of acquisition memory or the sampling rate of the digitizer.

Combining channels

Certain digitizers offer the possibility of combining the converters (and their memories) from two or four channels to analyze a single input channel. With this feature the maximum sampling rate and the maximum amount of acquisition memory can be doubled or quadrupled if all of the input channels are not of immediate interest.


Internal Calibration

The digitizer includes a high precision voltage source and a 16-bit DAC, used to perform the input voltage and offset calibration.

The software drivers supplied include calibration functions for the timing, gain and offset parameters, which can be executed upon user request. The digitizers are never calibrated in an “automatic” way, (i.e. as a side effect of another operation). This ensures programmers have full control of all calibration operations performed through software in order to maintain proper event synchronization within automated test applications.

For accurate time and voltage measurements it is recommended to perform a calibration once the module has attained a stable operating temperature (usually reached with a few minutes of digitizer operation after power on). And subsequently a self-calibration should be carried out after any configuration changes are made to the digitizer, before making acquisitions.

A full internal calibration of a digitizer can be time consuming. Therefore, several other options are available. They are documented in the calibration routines associated with the API. A program can always be started with the digitizer in an un-calibrated state and data taken can be used for many kinds of testing. However, as soon as good data respecting the specifications of the instrument is required a calibration of at least the current acquisition state is needed. The full internal calibration has the advantage that it generates the calibration constants needed for any possible configuration of the instrument; its disadvantage is the time taken. If a more selective calibration is done it will allow the generation of good data in the current acquisition state. This calibration will remain useable whenever that acquisition state is used again for as long as the temperature of the instrument does not change significantly. A fast calibration of a channel in a configuration can be done in around a 5 seconds. Many applications can save time by only performing calibration for the configurations that will actually be used.

Calibration can usually be performed with signals present at the channel, external, and clock inputs. However, to ensure the best performance, or if the calibration is found to be unreliable, as shown by a calibration failure status, it will be necessary to remove such signals.

An application program will close devices if it exits normally. When a digitizer is closed in this way its power consumption will be reduced. This has the consequence that if another application program is started later an appropriate warm-up period may have to be respected before a calibration is called for and full performance expected.

Factory Calibration

Whilst the Internal Calibration function will provide a good degree of confidence that your instrument is operating within its specifications on a day-to-day basis, Agilent recommends that each instrument undergoes a Factory Calibration at least annually to ensure that it remains within the specified performances.

Factory Calibration is the process of measuring the actual performance of an instrument-under-test using lab instruments that in turn have significantly better performance than the instrument-under-test. Lab instrument performance must be traceable to the International System (SI) Units via a national metrology institute (NIST, NPL, NRC, PTB, CENAM, INMETRO, BIPM, etc.)

The measured performance is then compared to published data sheet specifications. Agilent Technologies tests the performance corresponding to all data sheet specifications, for all installed options, every time. If we observe your instrument to be out-of-specification, we always adjust it and re-test before we return it to you.

For more information, or to return your instrument to Agilent for calibration please see www.agilent.com/find/calibration


External Trigger Output

You are here: U1084A User Manual > Trigger Output

Trigger Output

When the digitizer is ready to be triggered and a valid trigger signal occurs, a trigger output is generated for external use. This signal is available on the front panel connector, and may be enabled or disabled as required. The pulse ends when the data acquisition for the trigger in question is complete.

There are several trigger sources which may be assigned to the Trigger Out connector, but the available options will depend on the model being used.

Trigger Out Sources | Description of signal
(0) No Sync | The input trigger signal is sent directly to the Trigger Out.
(1) Sync | A trigger signal resynchronized to the sample clock is sent to the Trigger Out.
(3) Trig compare | The trigger input condition has been satisfied, but not necessarily triggered e.g the trigger enable was not asserted.
(17) High Level | Fixed 'high' level signal for debug purposes.
(18) Low Level | Fixed 'low' level signal for debug purposes.

Figure 1 - Trigger Output Block diagram:

In the default software configuration, the output swing is 1.6 V (±0.8 V) when unloaded and 0.8 V (±0.4 V) when terminated on 50 Ω. The rise and fall times are 2.5 ns typical. The offset can be adjusted, by software control in the range [–2.5 V to +2.5 V] unloaded, or [-1.25 V to +1.25 V] into 50 Ω. The maximum output current capability is ±15 mA. As the output is retro-terminated, it is possible to drive a 50 Ω line un-terminated (HiZ) without loss of performance.

For a TTL compatible signal, set the offset to 1.0 V and the swing at destination will be +0.2 to +1.8 V.

For an ECL compatible signal, terminated on 50 Ω to –1.2 V, set the offset to –1.2 V and the output will be in the range [–0.8 to –1.6 V]).

Alternatively, to reduce the current drawn from the digitizer, the terminations shown here can be used:

Figure 2 - Suggested trigger signal terminations

standardized trigger out signal can also be routed to the PXI Bus Star Trigger line.

The External Trigger Output functionality is implemented in the hardware. No Trigger Out signal occurs for software-generated triggers such as those of the AUTO mode of the SFP.


Special Inputs & Controls

You are here: U1084A User Manual > Multi-Purpose Inputs and Outputs

Multi-Purpose Inputs and Outputs

The I/O A, I/O B or I/O C may be used for any of the functions shown in the following table:

IO Connector Functions | Type | Description of signal | Notes
Inputs
Disabled | - | IO connector is disabled. |
In: Enable Acquisition | Level | Enables acquisition. See also (15) Start Veto. If both (1) and (15) are assigned as inputs then a logical AND is used. i.e. Acquisition is enabled IF (1) AND NOT (15) is true. | U1084A Averager & Peak TDC only.
In: Skip to Next Segment | Level | Forces the acquisition to jump to the next segment without waiting for a trigger, under certain conditions, see Programmers Reference, function - AcqrsD1_configControlIO | U1084A and DP214 Digitizers only.
In: Start Veto | Level | Inhibits acquisition. See also (1) Acquisition Enable. If both (15) and (1) are assigned as inputs then a logical AND is used. i.e. Acquisition is enabled IF (1) AND NOT (15) is true. | U1084A Averager & Peak TDC only. (not currently implemented in SFP 5.x)
Outputs |  |  |
Out: 10 MHz Reference Clock | Clock | To ensure good rise time characteristics the output impedance is 50 Ω.This signal can be used as an input to 1 (or 2 using a T split) CLK IN connectors. Note: This signal is the internal 10 MHz and is not available if the External Reference Clock is in use. | On U1084A the signal is only available on IO A.
Out: Skipping to next Seg | Pulse | Indicates that the acquisition has skipped to the next segment. This will occur in certain models which support the 'skip' command (see the Programmers Guide) or in normal digitizer operation at the end of each segment. | Not available on U1084A Averager & PeakTDC models or U1082A Signal Analyzers.
Out: Acquisition Active | Level | Indicates that the acquisition is currently running. |
Out: Trigger Armed | Level | Active when the instrument is armed and waiting for a valid trigger event. | Not available on U1084A Averager or PeakTDC
Out: Analyzer Armed | Level | High when the Averager is started and the trigger is enabled, returns low at the end of the entire sequence of averages. | U1084A Averager & Peak TDC only

To ensure proper operation of the segment recording of hardware markers, the logical state of I/O A, I/O B, and I/O C inputs must be stable for a time interval starting 30 ns before the trigger and continuing until 30 ns after it. This implies that the HF Reject trigger coupling should not be used. If the individual inputs are not in the disable state the corresponding bits will be useless.

Signal Logic Levels

The multi-purpose IO signals are 3.3 V CMOS compatible. The levels shown in the table below should be observed.

Direction | Low level | High level
Input | <0.8 V | >2.0 to 3.45 V
Output | In the range 0 to 0.8 V | In the range 1.6 to 3.3 V
As an Input

The input is high-impedance and will be pulled high if unconnected via an internal weak pull-up.

As an Output

The high level output will typically give 0.8 V into 50 Ω. As can be seen in the diagram below, the 3.3 V output buffer has a 50 Ω resistor in series. Therefore the available output high level voltage will depend on the load applied. In the example below a 50 Ω termination will result in a nominal high level of 1.6 V. (Vo = Rload/50 + Rload * 3.3)

Figure 3 - Output equivalent circuit


U1084A-DGS Digitizer with SAR Mode

When purchased with the -DGS option the U1084A may be operated in one of the following sub-modes:

  • Digitizer
  • Digitizer with SAR
  • Zero-Suppress (SSR) mode

Dual-bank SAR

This function which is also often referred to as 'Double-Buffer Accumulation' or 'Ping-Pong Accumulation' utilizes two accumulation memory buffers allow accumulation to continue in one buffer while the PCIe read out of a completed accumulation is under way from the other buffer. This helps to optimize the measurement throughput. While accumulation continues, the previous segment can be read out through the high speed PCIe bus at up to 520 MB/s.

This mechanism, together with sequence acquisition, helps achieve a high maximum continuous event rate in spite of interrupts due to the computer operating system. The maximum continuous event rate is the maximum value of the trigger frequency that can be accepted without the loss of any event. It will work for both 1 and 2 converter/channel modes.

Zero-Suppress (SSR) Mode

The U1084A supports a Zero-Suppress mode which allows null-data or data below a desired threshold to be excluded from the acquisition. This allows only the relevant portions of a signal to be acquired, thus optimizing the use of the data memory.

In order to implement this function the user may configure a set of thresholds (up to 128) which will be applied in sequence. Each threshold is specified by a value in Volts and the index of the sample in the segment at which the system should switch to the next threshold.

In the example below, the threshold line is shown in blue, and the acquired data in red. The threshold has been set-up as follows:

[0] Threshold = 0.25 (V), nextThreshSample = 10240
[1] Threshold = 0 (V), nextThreshSample = 20480
[2] Threshold = -0.25 (V), nextThreshSample = 30720
[3] Threshold = 0 (V)

Figure 4 - An example Zero-Supress Configuration

Figure 5 - An example Zero-Supress Acquisition

It should be noted that setting the threshold to the minimum value will cause the digitizer to save all of the acquired data, and conversely setting the value to maximum will cause no data to be saved. In this way a ‘pre-defined gate’ type acquisition may be achieved as in the example below:

Figure 6 - An example Zero-Suppress Acquisition used as Gating

Acquisition Parameters:

The following are the required parameters to configure the operation of the zero-suppress mode:

NbrSegments : The number of waveform segments to acquire.

NbrSamples : Nominal length of each segment in samples, counting all samples above or below the zero-suppression thresholds. This value must be a multiple of 2048 in dual channel mode (no channel combination), or 4096 in single channel mode (channels 1 & 2 combined). The maximum value depends on NbrSegments.

InvertData : Allows inversion of the acquired data.

PreSamples : Used to guarantee a number of samples before the first one which satisfies the threshold condition. This value must be a multiple of 16 in dual-channel mode (no channel combination), or 32 in single channel mode (channels 1 & 2 combined).

PostSamples : Used to guarantee a number of samples after the last one satisfying the threshold condition. This value must be a multiple of 16 in dual-channel mode (no channel combination), or 32 in single channel mode (channels 1 & 2 combined).

MaxSamplesPerSegment : Defines the maximum number of samples to be stored per segment in Zero-Suppression (gating) mode, per channel. This parameter can be used to limit the readout time.

Threshold Configuration Parameters:

Threshold parameters are defined by an array of up to 128 items, containing:

threshold : Threshold value in Volts.

nextThreshSample : The index of the sample in the segment at which the Zero-Suppression system should switch to the next threshold value.

Please refer to the Programmers Reference (U1092-90002) for further detail on configuration of this function.


U1084A-AVG Averager Mode

As a signal averager, the U1084A takes full advantage of the high-speed signal processing performance of the module to create real-time averaged signals to reduce random noise levels in repetitive signals.

Key features of the U1084A-AVG model are:

Improved Timing

In order to preserve the timing accuracy of successively summed acquisitions, U1084A Digitizers include a precise real-time measure of the trigger position relative to the sampling clock. In Non-Resync mode, the jitter (trigger positioning with respect to the clock from acquisition to acquisition) is as low as ± one-half clock cycle ( ± 125 ps @ 4 GS/s). For systems that can be externally triggered, the clock synchronized trigger output signal (synchronized with the internal clock to less than ± 60 ps) can be available on the front panel MCX.

Better Accuracy

Vertical resolution can also be improved with a special dithering circuit that can increase the dynamic range from 8 to 12 bits (when averaging more than 256 spectra). Dithering a signal involves the addition of a small, systematic, pseudo-random amount of DC offset to the acquired signal. The dithering range is user programmable within ± 12 ADC LSB’s. Dithering improves measurement resolution and can dramatically reduce the errors associated with ADC effects such as differential non-linearity.

Numerous front panel control signals

In order to ease the integration and synchronization of the Digitizer in a large variety of systems, a number of signals are made available on MCX connectors on the instruments front panel. The following high-speed timing signals are available : Inputs for Clock, Reference Clock, and Accumulation Start Enable, Outputs for Trigger, Trigger Ready, Acquisition state, and Reference Clock.

High Data Throughput

The U1084A Digitizer can easily be integrated into any standard computer with 1 free long PCIe x4 slot (minimum, can also be inserted in a x8 or a x16 slot) that provides the 3.3 V and 12 V supply voltages at adequate power as required by the card. The histogram can be transferred, in DMA mode, directly to the processor over the PCIe bus at rates of up to 520 Mbytes per second (3.9 ms for a 500 KS record, including DMA setup time overhead).

Base Line Subtraction

The Digitizer implements a fixed base line subtraction feature that is applied to the data values that are over the threshold. This can be used to greatly reduce the occurrence of data overflows. Therefore many more events can be accumulated before running the risk of data overflow.

Fast Averaging

The U1084A systems have two 32-bit, 32 MSample accumulation memory buffers/channel. The accumulation memory is updated in real time and contains the current summed converted data from the digitizer. A high-speed on-board computing circuit performs the retrieve, add and store functions necessary to accumulate the signal at the maximum sampling rate. At the highest sampling rate, summed events can be acquired with less than 1.8 µs dead time between them. For example, multiple acquisitions made at 4 GS/s sampling rate and containing 400 KSamples can be summed at sustained rates of up to 9800 shots per second. If 100 KSample records are used, the sustained summing rate can reach 37,300 shots per second. Once a sum is accumulated to the desired depth, a number of events selectable from one to 16,777,216 (224), the signal is read out over the PCIe bus and the division function necessary to obtain the average is performed inside the PC (if desired).

Sequence Average Modes

In time resolved applications, where multiple averaged waveforms must be acquired with very low dead time, the user can partition the averaging memory to store from 1 to 131072 separate accumulations of summed data. In standard segment accumulation mode the user selects the desired number of triggers per segment, N. The next segment will be started after the previous N triggers have been processed. For the single channel mode, the length of each segment is adjustable from 512 samples up to 512 K samples in steps of 512 points, while in the dual-channel mode it is adjustable from 256 samples to 256 K samples in steps of 256 samples.

Dual-bank SAR

This function which is also often referred to as 'Double-Buffer Accumulation' or 'Ping-Pong Accumulation' utilizes two accumulation memory buffers allow accumulation to continue in one buffer while the PCIe read out of a completed accumulation is under way from the other buffer. This helps to optimize the measurement throughput. While accumulation continues, the previous segment can be read out through the high speed PCIe bus at up to 520 MB/s.

Noise Suppressed Accumulation (NSA)

The Digitizer provides a noise suppression feature which makes it possible for the U1084A cards to enhance rarely occurring events, which, under most circumstances, disappear in signals with base line noise. Only data points that exceed a user-defined threshold are added to the result. This considerably reduces the noise contribution and the signal-to-noise ratio is enhanced. Furthermore, the NSA mode implements a fixed base line subtraction feature that is applied to the data values that are over the threshold. This can be used to greatly reduce the occurrence of data overflows. Therefore many more events can be accumulated before running the risk of data overflow.

Segment accumulation

In time-resolved applications where multiple averaged waveforms must be acquired with very low dead time, the averaging memory can also be segmented. This allows the user to store from 1 up to 128 K separate accumulations of summed data. The segment length is user-programmable. In standard segment accumulation mode the user selects the desired number of triggers per segment, N, up to over 16 million. The next segment accumulation will be started after the previous N triggers have been processed. The memory in the U1084A averager is optimized to allow real-time acquisition and averaging. At the end of each average segment, a dead time exists before a new average can be stored. The dead time duration depends on the size of the segment, a 162 KS segment will incur a 1 ms dead time.

Vertical Resolution

In the Averaging mode, vertical resolution increases over the normal mode as the number of acquisitions per average increases. It can be improved to up to 12 bits when averaging 256 or more traces.

Averaging Mode

In Averaging mode, newly acquired waveforms are summed in real time with the corresponding samples of previous waveforms. The corresponding samples are those with identical delay calculated from the beginning (trigger time) of the acquisition. While the acquisition is running, the previous sum is read from the averaging memory, added to the incoming sample and written back to the averaging memory. A high-speed on-board computing circuit performs the retrieve, add, and store functions necessary to average the signal in real time. Real-time averaging is possible up to the maximum 4 GS/s sampling rate. In Averaging mode only post-trigger data are acquired. Each raw ADC datum is treated as a value in the range [0, 255], which corresponds to the voltage range [–FS/2 – Offset, +FS/2 – Offset].

Data Acquisition - Averaging Mode
Model - Mode | Channels | Maximum Sampling Rate | Maximum length for Average (samples) | Memory Minimum Increment (samples) | Sequence Maximum length (samples) | Start Delay / Stop Delay Maximum (samples)
U1084A - Single channel (combined) | 1 | 4 GS/s | 524288 | 512 | 64 M | 128 M
U1084A - Dual channel | 2 | 2 GS/s | 262144 | 256 | 32 M | 64 M
Single Average

The data associated with successive triggers is summed in a segment until the desired depth, Nsucc, is attained.

When a single average is acquired, the series of events shown in the diagram below take place:

  • After a software Start command, beginning of accumulation can be delayed with external input control.
  • The trigger starts the acquisition until the number of programmed triggers Nsucc is attained.
  • The U1084A will accumulate the successive acquisitions in a single average and then stops.

Tanarm is typically 40 ns.
TtrigOut is typically 13 ns.
Toff is a minimum of 1.8 us.
Teos can be calculated by: (Nbr_samples / 196) + 3 [us]

Sequence Average Mode

For time resolved applications where multiple averaged waveforms must be acquired with minimal dead time between them, the Sequence Average mode is available. This mode partitions the averaging memory into a pre-selected number of segments. Each memory segment is then used to store accumulations of summed data. The number of waveforms in the accumulation is identical for all segments.The number of segments Ssucc can be chosen from 1 to 131072.

When a sequence average is acquired, the series of events shown in the diagram below takes place:

  • After a software Start command, beginning of accumulation can be delayed with external input control.
  • The trigger starts the acquisition until the number of programmed triggers Nsucc is attained for each segment. The module needs as many triggers as defined by the sequence setting, Nsucc * Ssucc.
  • The U1084A will accumulate the successive acquisitions for each segment and then stops.

It should be noted that the normal Sequence Average mode is not at all like the Sequence Acquisition Mode of other Acqiris digitizers. The data associated with successive triggers is summed in a segment until the desired depth, Nsucc, is attained. The next trigger initiates the sum of the following segment. Round-robin sequence acquisition is not available.

To complement the Sequence Average mode, the digitizer can also measure and store the times when the first trigger of each segment occurred. Readout of the time stamps allows the determination of the time from the beginning of one Average to that of any other Average in the sequential acquisition. Timing measurements between these trigger events are possible with a resolution of ~8 ns at the maximum sampling rate and ~16 ns otherwise.

The digitizer can also store the state of 3bits at the time of the first trigger of each segment of each acquisition. These bits, which will be called hardware markers, are those of logic signals at the MCX I/O A, MCX I/O B, and MCX I/O C inputs.

SAR Sequence Average Mode

In order to maximize the measurment throughput, the simultaneous accumulation and readout (SAR) mode operates on a double buffer accumulation memory and enables readout to the host PC of a completed sequence average while another sequence is started.

When a sequence average is acquired in SAR mode, the series of events is identical to the normal sequence of average with the exception that another sequence of average can be restarted as soon as the ongoing sequence average is completed.

In SAR mode the double buffer bank switching is automatically controlled by the driver after new acquire commands are executed.

The SAR sequence average mode must be stopped with a stop command.

Time Base Range

The Time Base Range defines the time period over which data is being acquired. For example, the U1084A in single-channel mode has an averaging acquisition memory of 524288 S and maximum sampling rate of 4 GS/s. Thus, at the maximum sampling rate, the digitizer can record a signal over a time period of up to 131 µs (0.5 MS * 0.25 ns/point). The time base range can be adjusted by varying the amount of acquisition memory or the sampling rate of the digitizer.

Averaging Memory

Data from the ADC is stored in the on-board averaging memory. The actual averaging memory size used for each acquisition can be programmed. The maximum values are given in the table above.

The sums are stored in the 32-bit deep averaging memory, allowing the summation of up to 16,777,216 waveforms, without overflow.

Although the averaging memory permits to store a total of 64 M points, the length of one average, is limited to 512 or 256 Kpoints. This is due to the averaging memory topology. The entire averaging memory can be fully used in the sequence average mode.

A segment time stamp associated with the first trigger of each accumulation and the necessary segment descriptors are also stored in memory.

To ensure the use of maximum sampling rate and high timing resolution, we strongly recommend the use of long averaging memories whenever possible. For example, the model can simultaneously record 2 signals over a 100 µs period at the full 2 GS/s sampling rate. The fast sampling rate ensures that high frequency signal components are accurately recorded. If the averaging memory were reduced to just 20 KS then the sampling rate would need to be reduced to just 200 MS/s (20,000/100 µs) to record the same 100 µs period. All frequencies above 100 MHz would then be incorrectly digitized and important signal characteristics may be distorted or even completely missed.

Trigger Overview

Before the digitizer starts acquiring signals it must be armed and in a ready state. Arming the module is done by software (ACQUIRE command). The digitizer will then wait for a trigger to start an acquisition (see the timing diagram below).

When the AcqrsD1_acquire command is executed the module will receive the command after a time Tst which may vary between 50 ms and even more than 100 ms, depending on the processor and the operating system used. The module will be ready to acquire after the optional hardware Enable Acquisition delay Tenacq and fixed delay Tanarm. The Acquisition Armed signal is then driven active and is optionally available on the front panel I/O MCX connector. It is normally used to enable external events, such as laser firings.

These external events in turn can produce signals that can be used to generate the triggers for the digitizer. The trigger-input pulse can have a delay Ttrig that can vary from zero to as long as required.

When the trigger is received, the digitizer generates a trigger output and starts the acquisition after a predetermined StartDelay. StartDelay is adjustable from its minimum as given in the table above, in steps of the time of the memory increment value, up to the maximum value given in the table above.

The digitizer can be used to limit the system’s overall event rate. A rate adjustment delay StopDelay can be programmed in steps from zero to the model maximum with the same range and resolution as StartDelay. For maximum acquisition rates StopDelay should be set to zero.

Random and Synchronized Triggers

In the normal mode the trigger output is a low jitter copy of the trigger input with a fixed delay, TtrigOut of aprox. 13 ns. This mode is also called the Non-Resync mode in analogy with the same mode of previous generation of Acqiris Averager.

In Non-Resync mode, start of the acquisition has a jitter, shot to shot of +/- half the sampling period relative to either the internal trigger or to the external trigger out signal.

In order to preserve the timing accuracy of successively summed acquisitions, the digitizer also offer the mode SyncOnTrigOutSync. In this mode the external trigger out signal is synchronized to the internal sampling clock to within < 50 ps. Any external event triggered synchronously to the external trigger out signal will show a jitter shot to shot below 50 ps.

The SyncOnTrigOutSync mode is the preferred method for applications where the acquisition jitter must be minimized to avoid loss of effective system bandwidth typically associated with the higher jitter found when using the Non-Resync mode. Ideally, the trigger output is used to synchronously activate an event serving as the zero-time reference for the time-dependent phenomena that are measured in each accumulated waveform. As an example, the trigger output could activate the application of an electric or magnetic field to a sample under test. This method ensures that the application of the field is identically synchronized to the sample clock for each shot contained within the average. It also means that each sample in the accumulated sum is identically positioned shot-to-shot with respect to a fixed zero-time reference, provided that the time between the trigger output and the event waveform is kept constant.

The jitter, i.e. the variation of the position of the trigger out signal with respect to the start of the acquisition, as a function of sampling rate is shown in the table below.

Table 1 - Start of acquisition sync with respect to Trigger Output
Sample Rate | SyncOnTrigOutSync Mode |  | Non-Resynchronized Mode
 | Single channel (combined) | Dual channel | Single channel (combined) | Dual channel
4 GS/s | ± 60 ps | - | ± 125 ps | -
2 GS/s | ± 60 ps | - | ± 250 ps | ± 250 ps
1 GS/s | ± 60 ps | ± 60 ps | ± 250 ps | ± 500 ps
500 MS/s | ± 60 ps | ± 60 ps | ± 250 ps | ± 500 ps
< 250 MS/s | ± 60 ps | ± 60 ps | ± 250 ps | ± 500 ps
Pre Acquisition Triggers

For applications where thermal effects must be taken into account, the digitizer module has the capability of generating trigger output pulses that can be used to activate the system even when the associated event will not be acquired. The trigger output pulses can be used to stabilize systems prior to starting the acquisition. A call to AcqrsD1_configAvgConfig using the parameter string "TrigAlways" will cause these pulses to be generated. The trigger rate should not exceed that which can normally be taken under the chosen acquisition conditions.

Noise Suppressed Accumulation

In some applications, such as time of flight mass spectroscopy, the signal is a rare event sitting on top of a noisy base line. The averaging process will reduce the random noise. However, to enhance the Accumulation’s ability to detect such signals in the presence of synchronous noise, the digitizer allows the user to set a threshold that has to be exceeded for each data value to be entered into the sum. The threshold should be set above the level of the noise (synchronous and asynchronous). Furthermore, as an aid to the user or in order to avoid overflow in the summed data, a fixed number, the NoiseBase, can be subtracted from each data value before the summation is done. Both of these values are specified as absolute voltages, Vthresh and Vbase , which are converted into their ADC code equivalent values, base and threshold. This is shown in the following picture:

Thus, for each trigger and in each time bin, i, if the data value exceeds the threshold then the threshold minus the base value will be added to the sum, si:

and,

where N is the total number of acquisitions,

and where

and

Note: that Vbase can be below Vlower edge of range if so desired.

Similarly, if the signal of interest is negative going and the data of interest lie below a threshold, data inversion can be enabled and the application of the same recipe gives the same result for the following input:

and,

where N is the total number of acquisitions,

and where

and

Note: that Vbase can be above Vupper edge of range if so desired.

The result of this is that the summed or averaged data always shows positive peaks. In order to ensure that the threshold can be applied and that the values contributing to the sum are always positive and because the base value is stored as a signed 8-bit number it is required that:

For positive going signals (data above a threshold)

, or equivalently.

threshold >= Vbase and

, or equivalently,

For negative going signals (data below threshold)

, or equivalently.

threshold <= Vbase and

, or equivalently,

The average value is obtained by dividing the sum by the total number of triggers which is often much greater than the number of triggers that actually contributed to the sum. The interpretation of the absolute voltage value is not obvious.

Digitizer Mode

When purchased with only the -AVG option a simple digitizer mode is also included. This mode is not as fully featured as the -DGT or -DGS options but provides a reduced digitizer function.

Acquisition Memory and Time Base Range - Digitizer Mode

Data from the ADC is stored in on-board acquisition memory. The amount of memory in use for acquisition can be programmed and is selectable from 2 samples to 16KS in combined channel mode. Note that the Accumulation’s memory is much greater. The raw ADC data is treated as a value in the range [-128, +127], which corresponds to the voltage range [–FS/2 – Offset, +FS/2 – Offset].

For technical reasons, a certain memory “overhead” is required for each waveform, reducing the available memory by a small amount. In order to simplify programming, an interface function recommends the best sampling rate and the maximum possible number of data points, taking into account the available memory, the requested time window, as well as the required memory overhead.

The Time Base Range defines the time period over which data is being acquired. For example, the U1084A in the dual channel digitizer mode has an acquisition memory of just under 8 KS and maximum sampling rate of 2 GS/s. Thus, at the maximum sampling rate, the digitizer can record a signal over a time period of up to ~4 μs (~8 KS * 0.5 ns/point). The time base range can be adjusted by varying the amount of acquisition memory or the sampling rate of the digitizer.

Pre- and Post-Trigger Delay - Digitizer Mode

To increase trigger flexibility a pre- or post-trigger delay can be applied to the trigger position. However, pre-trigger is not available in the Averaging mode.

The amount of pre-trigger delay can be adjusted between 0 and 100% of the acquisition time window (i.e. sampling interval x number of samples), whereas the post-trigger delay can be adjusted between 0 and ~2 billion samples.

Pre- or post-trigger delays are just different aspects of the same trigger positioning parameter:

The condition of 100% pre-trigger indicates that all data points are acquired prior to the trigger, i.e. the trigger point is at the end of the acquired waveform.

The condition of 0% pre-trigger (which is identical to a post-trigger of 0) indicates that all data points are acquired immediately after the trigger, i.e. the trigger point is at the beginning of the acquired waveform.

The condition of a non-zero post-trigger delay indicates that the data points are acquired after the trigger occurs, at a time that corresponds to the post-trigger delay, i.e. the trigger point is before the acquired waveform.

The digitizer hardware accepts pre- and post-trigger adjustments in increments of 16 samples. By definition post-trigger settings are a positive number and pre-trigger settings are a negative number.

Thus it is only natural that the software drivers provided treat pre- and post-trigger delays as a single parameter in seconds that can vary between –nbrSamples * samplingInterval (100% pre-trigger) and +maxPostTrigSamples * samplingInterval (max post-trigger). Since the Acqiris software drivers provide very accurate trigger position information upon waveform readout, the accepted resolution of the user-requested pre-/post-trigger delay is much better than 16 samples. For more details, refer to the Programmer’s Reference Manual.

Single Acquisitions - Digitizer Mode

Digitizers acquire waveforms in association with triggers. Each waveform is made of a series of measured voltage values (sample points) provided by the ADC at a uniform clock rate. An acquisition consists of a waveform recorded with a single trigger. The user selects the sampling rate and acquisition memory size. The number of segments is always set to 1.

The modules also include a built-in Trigger Time Interpolator (TTI) that measures the time from the trigger point to the first sample point. This information is essential for determining the precise relation between the trigger or other event of interest and the digitized samples of the signal. The TTI resolution is ~8 ps.

Using the U1084A with SFP 5.x

For general information on the operation of the U1084A in Averager mode with SFP 5.x, please refer to the MD1 SFP Help. Specific information for the U1084A is given in the following paragraphs:

Time Stamps

Clicking on the Time Stamps button will open a separate window which shows the segment time stamp information.

The first column shows the segment index number.

The second column is a set of status flags. For U1084A these flags are as follows:

Bit 3 (MSB) | Bit 2 | Bit 1 | Bit 0 (LSB)
I/O C | I/O B | I/O A | SSR Bank

The third column shows the time information in ps. This will be either the time since the module has been restarted / reset, or the start of the acquisition depending on the model being used. This counter may also be reset manually by software, please refer to the Programmers Reference for more detail (AcqrsD1_acquireEx function).

The last column shows the difference in ps from the start of the previous segment to the start of the current one.


U1084A-TDC Peak TDC Mode

The U1084A peak detection and analysis firmware option (U1084A-TDC) allows real-time acquisition and peak detection at up to 4 GS/s (down to 488.28 kS/s with binary sparsing). The PeakTDC option enables the creation of of a histogram of peak position versus time for successive acquisitions, the histogram bins containing peak counts or summed peak amplitudes.

A large FIFO is used to provide peak overflow protection; In the event that a burst of peaks causes congestion in the data flow, none of the previously acquired data will be lost.

Key Features of the U1084A-TDC model are:

Improved Timing

In order to preserve the timing accuracy of successively summed acquisitions, U1084A Digitizers include a precise real-time measure of the trigger position relative to the sampling clock. In Non-Resync mode, the jitter (trigger positioning with respect to the clock from acquisition to acquisition) is as low as ± one-half clock cycle ( ± 125 ps @ 4 GS/s). For systems that can be externally triggered, the clock synchronized trigger output signal (synchronized with the internal clock to less than ± 60 ps) can be available on the front panel MCX.

Better Accuracy

Vertical resolution can also be improved with a special dithering circuit that can increase the dynamic range from 8 to 12 bits (when averaging more than 256 spectra). Dithering a signal involves the addition of a small, systematic, pseudo-random amount of DC offset to the acquired signal. The dithering range is user programmable within ± 12 ADC LSB’s. Dithering improves measurement resolution and can dramatically reduce the errors associated with ADC effects such as differential non-linearity.

Numerous front panel control signals

In order to ease the integration and synchronization of the Digitizer in a large variety of systems, a number of signals are made available on MCX connectors on the instruments front panel. The following high-speed timing signals are available : Inputs for Clock, Reference Clock, and Accumulation Start Enable, Outputs for Trigger, Trigger Ready, Acquisition state, and Reference Clock.

High Data Throughput

The U1084A Digitizer can easily be integrated into any standard computer with 1 free long PCIe x4 slot (minimum, can also be inserted in a x8 or a x16 slot) that provides the 3.3 V and 12 V supply voltages at adequate power as required by the card. The histogram can be transferred, in DMA mode, directly to the processor over the PCIe bus at rates of up to 520 Mbytes per second (3.9 ms for a 500 KS record, including DMA setup time overhead).

Base Line Subtraction

The Digitizer implements a fixed base line subtraction feature that is applied to the data values that are over the threshold. This can be used to greatly reduce the occurrence of data overflows. Therefore many more events can be accumulated before running the risk of data overflow.

Fast PeakTDC detection

Due to the incredible sampling speeds of the U1084A, the peak analysis firmware uses a very simple yet powerful algorithm to detect signal peaks at full 4 GS/s sampling rate.Nine samples are used to validate if a sample corresponds to a peak; the sample itself, along with the samples before and after that sample are considered.

The sample will be considered as a peak, if within the 9 samples analyzed: a rising edge is found before the sample that exceeds the programmable delta DRise, a falling edge is found after the sample that exceeds the programmable delta DFall, and the sample is the maximum of all points between the two defined rising and falling edges. There is additional verification to make sure that only one peak is found within the rising and falling edge region.

PeakTDC Interpolation mode

To improve the measurement, peak time and amplitude can be determined using an interpolation routine. Fitting a 12-bit quadratic spline to the 3 points around the extrema found by the peak detection algorithm, the position of a peak maximum is found and defined by its time (Tmax) and amplitude (Vmax).

PeakTDC Histogram

The interpolation method provides measurements with improved time and vertical resolution. The resulting histogram that is created can contain up to 2 Mbins of data, with each bin width down to 1/16th of the sampling period, peak amplitude encoded with the bins, to 1/16th of the ADC resolution. Adjustable through software commands, the user can balance the increased timing and vertical resolution against increased memory usage and reduced measurement throughput, to best fit requirement.

Data Acquisition - PeakTDC Histogram Mode
Model - Mode | Channels | Maximum Sampling Rate | Maximum Segment length (samples) | Memory Minimum (samples) | Increment (samples) | Histogram Maximum Bin Count (samples) | Start Delay / Stop Delay Maximum (samples)
U1084A - Single channel (combined)The U1084-TDC firmware does not support synchronous dual-channel sampling 1 | 1 | 4 GS/s | 589824 | 64 | 32 | 2 M | 128 M
Peak Histogram Mode

In Peak Histogram mode, newly peak flows are summed in real time with the corresponding peaks of previous waveforms. The corresponding peaks are those with identical position calculated from the beginning (trigger time) of the acquisition. While the acquisition is running, the previous peak information is read from the histogram memory, added to the incoming peak information and written back to the histogram memory. Real-time peak detection, peak interpolation and peak histograming are possible up to the maximum 4GS/s sampling rate. In Peak Histogram mode only post-trigger data are acquired. The sums are stored in a 32-bit deep histogram memory, allowing the summation of up to 16'777'216 waveforms, without overflow. ADC datum is treated as a value in the range [0, 255], which corresponds to the voltage range [-FS/2 - Offset, +FS/2 - Offset].

Time Base Range

The Time Base Range defines the time period over which data is being acquired. For example, the U1084A in peak TDC mode has an acquisition memory of maximum 589824 samples and maximum sampling rate of 4 GS/s. Thus, at the maximum sampling rate, the digitizer can record a signal over a time period of up to 147 µs (589824 * 0.25 ns/point). The time base range can be adjusted by varying the amount of acquisition memory or the sampling rate of the digitizer.

Peak Histogram Memory

The histogram is an indication of the peak occurrence versus time, relatively to the trigger position. Peak Amplitude and Position determined by the Peak detector are used to increment the peak histogram in the on-board peak histogram memory. The actual peak histogram memory size used for each acquisition can be programmed. The maximum values are given in the table on the preceding page.

The histogram sums are stored in the 32-bit deep histogram memory, allowing the summation of up to 16,777,216 waveforms, without overflow.

Although the histogram memory permits to store a total of 2M bins, the number of bin in the histogram is limited to 589824 bins when interpolation is not used. It should be noticed this number is equal to the maximum number of sample that can be acquired in a segment in histogram mode.An histogram time stamp associated with the first trigger of each histogram and the necessary segment descriptors are also stored in memory.

To ensure the use of maximum sampling rate and high timing resolution, we strongly recommend the use of long peak histogram memory whenever possible. For example, the model can record 1 signal over a 100 µs period at the full 4GS/s sampling rate. The fast sampling rate ensures that high frequency signal components are accurately recorded. If the averaging memory were reduced to just 50 KS then the sampling rate would need to be reduced to just 500 MS/s (50,000/100 µs) to record the same 100 µs period. All frequencies above 250 MHz would then be incorrectly digitized and important signal characteristics may be distorted or even completely missed.

Single Histogram

The data associated with successive triggers is analyzed and peak information are summed in a single histogram until the desired depth, Nsucc, is attained.

When a single histogram is acquired, the series of events shown in the diagram below take place:

  • After a software Start command, beginning of histogram can be delayed with external input control.
  • The trigger starts the acquisition until the number of programmed triggers Nsucc is attained.
  • The U1084A will histogram the peaks of the successive acquisition in a single histogram and then stops.

Tanarm is typically 36 ns
TtrigOut is typically 13 ns

Although minimum value for Toff is 1.8 us and 0 us for Teos, both delay strongly depends on the number of peaks found in the acquisitions and also depends on when the peaks are encountered in the acquisition sequence.

When the average number of peaks to be analyzed exceed the rate of 125 Mpeaks/s, increase of Toff and/or increase of Teos might occur. In this case, triggers can be skipped to prevent the internal peak fifo to overflow. All waveforms participating to the histogram are always entirely analyzed.

To complement the Histogram mode, the digitizer can also measure and store the times when the first trigger participating to the segment histogram occurred. Readout of the time stamps allows the determination of the time from the beginning of one Histogram to that of any other Histogram. Timing measurements between these trigger events are possible with a resolution of ~8 ns at the maximum sampling rate and ~16 ns otherwise.

The digitizer can also store the state of 3 bits at the time of the first trigger of each segment of each acquisition. These bits, which will be called hardware markers, are those of logic signals at the MCX I/O A, MCX I/O B, and MCX I/O C inputs.

Histogram and Interpolation

When interpolation is not used, the histogram's horizontal bin width is equal to the sample rate period. If interpolated peaks are being calculated, the histogram's horizontal bin width can be selected to be a fraction of a sample interval. The allowed choices are 1/1, ½, ¼, 1/8, and 1/16 of the nominal bin width. Similarly the granularity of the contents of each bin can be chosen to be ½, ¼, 1/8, or 1/16 of an ADC LSB.

This table summarize the maximum possible acquisition length and maximum number of bin available in the histogram versus the time resolution setting of the interpolation.

Table 2 - Maximum acquisition length vs. time resolution of the interpolation
Interpolation Mode | Resolution of interpolation (fraction of sample rate period) | Maximum number of samples in the waveform | Maximum number of Bins in the histogram
Disabled | 1/1 | 589,824 | 589,824
Enabled | 1/1
 | 1/2 |  | 1,179,648
 | 1/4 | 524,288 | 2,097,152
 | 1/8 | 262,144
 | 1/16 | 131,072

This table below summarizes the maximum possible number of waveforms participating to the histogram versus the amplitude resolution of the interpolation

Table 3 - Maximum waveforms vs. amplitude resolution of the interpolation
Interpolation Mode | Resolution of interpolation (fraction of the ADC LSB) | Maximum number of waveforms in the histogram
Disabled | 1/1 | 16,777,216
Enabled | 1/1
 | 1/2 | 8,388,608
 | 1/4 | 4,194,304
 | 1/8 | 2,097,152
 | 1/16 | 1,048,176

Trigger Overview

Before the digitizer starts acquiring signals it must be armed and in a ready state. Arming the module is done by software (ACQUIRE command). The digitizer will then wait for a trigger to start an acquisition (see the timing diagram below).

When the AcqrsD1_acquire command is executed the module will receive the command after a time Tst which may vary between 50 ms and even more than 100 ms, depending on the processor and the operating system used. The module will be ready to acquire after the optional hardware Enable Acquisition delay Tenacq and fixed delay Tanarm. The Acquisition Armed signal is then driven active and is optionally available on the front panel I/O MCX connector. It is normally used to enable external events, such as laser firings.

These external events in turn can produce signals that can be used to generate the triggers for the digitizer. The trigger-input pulse can have a delay Ttrig that can vary from zero to as long as required.

When the trigger is received, the digitizer generates a trigger output and starts the acquisition after a predetermined StartDelay. StartDelay is adjustable from its minimum as given in the table above, in steps of the time of the memory increment value, up to the maximum value given in the table above.

The digitizer can be used to limit the system’s overall event rate. A rate adjustment delay StopDelay can be programmed in steps from zero to the model maximum with the same range and resolution as StartDelay. For maximum acquisition rates StopDelay should be set to zero.

Random and Synchronized Triggers

In the normal mode the trigger output is a low jitter copy of the trigger input with a fixed delay, TtrigOut of aprox. 13 ns. This mode is also called the Non-Resync mode in analogy with the same mode of previous generation of Acqiris Averager.

In Non-Resync mode, start of the acquisition has a jitter, shot to shot of +/- half the sampling period relative to either the internal trigger or to the external trigger out signal.

In order to preserve the timing accuracy of successively summed acquisitions, the digitizer also offer the mode SyncOnTrigOutSync. In this mode the external trigger out signal is synchronized to the internal sampling clock to within < 50 ps. Any external event triggered synchronously to the external trigger out signal will show a jitter shot to shot below 50 ps.

The SyncOnTrigOutSync mode is the preferred method for applications where the acquisition jitter must be minimized to avoid loss of effective system bandwidth typically associated with the higher jitter found when using the Non-Resync mode. Ideally, the trigger output is used to synchronously activate an event serving as the zero-time reference for the time-dependent phenomena that are measured in each accumulated waveform. As an example, the trigger output could activate the application of an electric or magnetic field to a sample under test. This method ensures that the application of the field is identically synchronized to the sample clock for each shot contained within the average. It also means that each sample in the accumulated sum is identically positioned shot-to-shot with respect to a fixed zero-time reference, provided that the time between the trigger output and the event waveform is kept constant.

The jitter, i.e. the variation of the position of the trigger out signal with respect to the start of the acquisition, as a function of sampling rate is shown in the table below.

Table 4 - Start of acquisition sync with respect to Trigger Output
Sample Rate | SyncOnTrigOutSync Mode |  | Non-Resynchronized Mode
 | Single channel (combined) | Dual channel | Single channel (combined) | Dual channel
4 GS/s | ± 60 ps | - | ± 125 ps | -
2 GS/s | ± 60 ps | - | ± 250 ps | ± 250 ps
1 GS/s | ± 60 ps | ± 60 ps | ± 250 ps | ± 500 ps
500 MS/s | ± 60 ps | ± 60 ps | ± 250 ps | ± 500 ps
< 250 MS/s | ± 60 ps | ± 60 ps | ± 250 ps | ± 500 ps
Pre Acquisition Triggers

For applications where thermal effects must be taken into account, the digitizer module has the capability of generating trigger output pulses that can be used to activate the system even when the associated event will not be acquired. The trigger output pulses can be used to stabilize systems prior to starting the acquisition. A call to AcqrsD1_configAvgConfig using the parameter string "TrigAlways" will cause these pulses to be generated. The trigger rate should not exceed that which can normally be taken under the chosen acquisition conditions.

Digitizer Mode

When purchased with only the -TDC option a simple digitizer mode is also included. This mode is not as fully featured as the -DGT or -DGS options but provides a reduced digitizer function.

Acquisition Memory and Time Base Range - Digitizer Mode

Data from the ADC is stored in on-board acquisition memory. The amount of memory in use for acquisition can be programmed and is selectable from 2 samples to 16KS in combined channel mode. Note that the Accumulation’s memory is much greater. The raw ADC data is treated as a value in the range [-128, +127], which corresponds to the voltage range [–FS/2 – Offset, +FS/2 – Offset].

For technical reasons, a certain memory “overhead” is required for each waveform, reducing the available memory by a small amount. In order to simplify programming, an interface function recommends the best sampling rate and the maximum possible number of data points, taking into account the available memory, the requested time window, as well as the required memory overhead.

The Time Base Range defines the time period over which data is being acquired. For example, the U1084A in the dual channel digitizer mode has an acquisition memory of just under 8 KS and maximum sampling rate of 2 GS/s. Thus, at the maximum sampling rate, the digitizer can record a signal over a time period of up to ~4 μs (~8 KS * 0.5 ns/point). The time base range can be adjusted by varying the amount of acquisition memory or the sampling rate of the digitizer.

Pre- and Post-Trigger Delay - Digitizer Mode

To increase trigger flexibility a pre- or post-trigger delay can be applied to the trigger position. However, pre-trigger is not available in the Averaging mode.

The amount of pre-trigger delay can be adjusted between 0 and 100% of the acquisition time window (i.e. sampling interval x number of samples), whereas the post-trigger delay can be adjusted between 0 and ~2 billion samples.

Pre- or post-trigger delays are just different aspects of the same trigger positioning parameter:

The condition of 100% pre-trigger indicates that all data points are acquired prior to the trigger, i.e. the trigger point is at the end of the acquired waveform.

The condition of 0% pre-trigger (which is identical to a post-trigger of 0) indicates that all data points are acquired immediately after the trigger, i.e. the trigger point is at the beginning of the acquired waveform.

The condition of a non-zero post-trigger delay indicates that the data points are acquired after the trigger occurs, at a time that corresponds to the post-trigger delay, i.e. the trigger point is before the acquired waveform.

The digitizer hardware accepts pre- and post-trigger adjustments in increments of 16 samples. By definition post-trigger settings are a positive number and pre-trigger settings are a negative number.

Thus it is only natural that the software drivers provided treat pre- and post-trigger delays as a single parameter in seconds that can vary between –nbrSamples * samplingInterval (100% pre-trigger) and +maxPostTrigSamples * samplingInterval (max post-trigger). Since the Acqiris software drivers provide very accurate trigger position information upon waveform readout, the accepted resolution of the user-requested pre-/post-trigger delay is much better than 16 samples. For more details, refer to the Programmer’s Reference Manual.

Single Acquisitions - Digitizer Mode

Digitizers acquire waveforms in association with triggers. Each waveform is made of a series of measured voltage values (sample points) provided by the ADC at a uniform clock rate. An acquisition consists of a waveform recorded with a single trigger. The user selects the sampling rate and acquisition memory size. The number of segments is always set to 1.

The modules also include a built-in Trigger Time Interpolator (TTI) that measures the time from the trigger point to the first sample point. This information is essential for determining the precise relation between the trigger or other event of interest and the digitized samples of the signal. The TTI resolution is ~8 ps.


Electrical & Environmental Specifications

This section describes the electrical and environmental specification and characteristics of the digitizers.

Electrical specifications

Model Number | PCI Rev. | DMA Transfer Rate(MB/s) | Max. Power Consumption |  | Max. Current Consumption (default / with optional memory)
 |  |  | Standard | With Options | +12 V | +5 V | +3.3 V | -12 V
U1084A | - | ≈520 | 40 | 50 | 2.5 | - | 4.0 | -

Environmental & Physical

Operating Temperature

5° to 40°C

Dimensions

The U1084A conforms to the PCIe full-length standard. Note that the rear fan unit uses 2 slots width, but may be turned by 180⁰ to accommodate differing PC / chassis dimensions, or to allow two U1084A units to be operated side-by-side. (see Appendix on Fan Assemblies).

EMC Immunity & Emissions

All models comply with:

  • European EMC Directive 2004/108/EC
  • IEC/EN 61326-2-1
  • CISPR Pub 11 Group 1, class A
  • AS/NZS CISPR 11
  • ICES/NMB-001 - This ISM device complies with Canadian ICES-001. Cet appareil ISM est conforme à la norme NMB-001 du Canada.
Required Airflow

> 2 m/s in situ for units dissipating > 30 W

In order to guarantee the above performance and specifications, PCI digitizer cards must be installed in a PCI metal frame with adequate cooling. The card’s front panel must be screwed to lock the digitizer into place and ensure proper grounding of the frame. The frame must not be used without closing all vacant front panel slots to guarantee EMC shielding and cooling. Similarly cPCI modules must be screwed to lock them into place and insure proper grounding. The crate must not be used without closing all vacant front panel slots to guarantee EMC shielding and cooling.

The U1084A Digitizers are supplied with a fan unit. This fan unit is required for operation, and should not be removed. This fan assembly takes up 2 PC slots at the rear. It has been designed to be mounted in either a left or right orientation to allow adaptation to different PC or chassis hardware, or also to allow two U1084A modules to be positioned side-by-side. See Fan Assembly information in the appendix.

Fan Assembly

The U1084A Digitizers are supplied with a fan unit. This fan unit is required for operation, and should not be removed.

The cooling fan assembly of the U1084A takes up 2 PC slots at the rear. It has been designed to be mounted in either a left or right orientation to allow adaptation to different PC or chassis hardware, or also to allow two U1084A modules to be positioned side-by-side.

To change the orientation please use the following procedure:

  1. Remove the 2 screws (top & bottom) nearest to the front of the fan unit, and remove the 2 retaining clips (shown pale red in the diagram).
  2. Slide the fan unit approximately 15mm to the rear unit it clears the circuit board, and rotate it by 180°.
  3. Slide the fan unit back towards the module until it is fully seated into the locating slots.
  4. Replace the 2 retaining clips, and refit and tighten the 2 screws (0.5 Nm torque).

To fit the module to the PC / chassis please use the following procedure:

  1. Loosen (but do not remove) the 4 screws holding the rear support bracket (shown in violet in the diagram), and slide it towards the fans.
  2. Insert the module into the PCIe slot of the PC or chassis, ensuring that it is fully seated into the PCIe bus connector..
  3. Fit a screw to the top front panel and tighten it.
  4. Fully extend the rear support bracket and ensure that it is inside the PCIe back plane rail.
  5. Tighten the 4 screws. (0.5 Nm torque)

Note: Older units have Philips screws requiring a No.2 driver, and newer models are fitted with Torx® headed screws requiring a T10 driver.

Both the front panel screw and the rear support bracket must be used to correctly support the unit. Failure to do this could result in damage to the unit.

The operating temperature specifications may be found in the U1084A datasheet, however it should be noted that the onboard temperature of the U1084A should not be allowed to rise above 52°C, as performance within specifications cannot be guaranteed above this temperature.


Programming Information

This section provides general programming advice and specific information regarding the use of the Agilent drivers.

Horizontal Parameters

Trigger Delay

Temperature


Horizontal Parameters

You are here: U1084A User Manual > Programming Information > Horizontal Parameters

Horizontal Parameters in Acquired Waveforms

Triggers usually occur asynchronously with respect to the sampling clock. Thus, between similar events, the time from the trigger to the next sampling clock varies randomly in the range [0 … sampInterval].

The true time reference for any waveform is the trigger point, not the sampling times, because the trigger is attached to a given feature of the waveform (e.g. a transition at a predetermined level). For highly stable displays, it is important to know the time between the trigger and the next sampling clock to within a fraction of the sampling interval, and to place the displayed data points in such a way that the trigger point stays at a constant position. This is particularly important for persistence displays or highly zoomed random-interleaved displays, as generated from overlaid segments, where a single waveform (or waveform segment) contributes only a few data points to the display.

Agilent digitizers feature a Trigger Time Interpolator (TTI), which measures the time between the trigger event and the next sampling clock to a fraction of the sampling interval. It permits very precise positioning of the acquired trace in highly zoomed displays, particularly when multiple acquisitions of the same signal are used. In many other applications, this value can be ignored.

The following drawing completes the description of a 'real-life' waveform:

  • The value of delayTime positions exactly the left edge of the display (or the exact nominal beginning of the waveform) with respect to the “stable” trigger time, which is the real reference point. We define the time 'trigger time + delayTime' as the time origin for the waveform, which is equivalent to saying that the trigger always occurs exactly at the time -delayTime.
  • The first data point of the waveform is defined as the last acquired data point before the time origin. It is indexed with i = 0 in the formula below.
  • The exact position of the first data point with respect to the time origin is a negative number horPos. It is by definition in the range [-sampInterval, 0].
  • The time between the trigger and the first data point hOffset need not be recorded since it can always be computed as delayTime + horPos. Note: delayTime + horPos < delayTime by definition.
  • In order to obtain a very stable image, even in a highly zoomed display, the user only needs to position the acquired data points with the aid of horPos, by using the following formula for the x-position of point i with respect to the left edge of the display:

x[i] = horPos + i * sampInterval


Trigger Delay

You are here: U1084A User Manual > Programming Information > Trigger Delay

Trigger Delay and Horizontal Waveform Position

When using a digitizer the user has 3 instrument setup variables with which to position the acquired waveform in time:

• sampInterval: the sampling interval (inverse of the sampling frequency or rate, )

• nbrSamples: the number of samples to acquire

• delayTime: the nominal trigger delay (also known as the Acquisition start time).

By convention, the nominal trigger delay is taken relative to the beginning of the trace, i.e. relative to the left edge of a real or virtual display grid. It can be interpreted as the time from the trigger to the start of waveform recording. If this number is positive, recording starts after the trigger (post-trigger acquisition). If it is negative, recording starts before the trigger (pre-trigger acquisition). In reality, the acquisition always runs before any trigger occurs, and delayTime controls the time between the trigger and the stopping of the acquisition:

delayTime | Time until Acquisition Stop | Comments
- sampInterval * nbrSamples | 0 | Trigger point is at the right edge of grid, i.e. at the end of the nominal waveform (100 % pre-trigger)
< 0 | sampInterval * nbrSamples + delayTime | Trigger point is at the desired point within the grid
0 | sampInterval * nbrSamples | Trigger point is at the left edge of grid, i.e. at the beginning of the nominal waveform (0 % pre-trigger)
> 0 | sampInterval * nbrSamples + delayTime | Trigger point is to the left of the grid, i.e. before the beginning of the nominal waveform (post-trigger)

That delayTime is not allowed to become more negative than - sampInterval * nbrSamples, because it is impossible to stop the acquisition before the trigger occurs.


Temperature

You are here: U1084A User Manual > Programming Information > Temperature

Reading the Instrument Temperature

The API contains routines to read the board temperature of the instrument.

The returned temperature value corresponds to the ambient temperature at a particular point on the main printed-circuit board, typically near the time base circuit. It cannot represent all possible temperature values that are present on the circuit.

Check the maximum permitted on-board temperature for your model from the User Manual or Datasheet. If values above this are being seen, then the module may be outside its operational limit. Check:

    • The cooling system is working and set correctly
    • Improve the cooling if required
    • That the ambient temperature is not too high

We recommend keeping the on-board temperature as low as possible, since a 10 °C reduction in circuit temperature is expected to improve the mean-time-between-failures (MTBF) by a factor of 2. Additionally a loss of performance may be apparent above the recommended maximum on-board temperature.

We also recommend reading the temperature when the instrument is stopped, since the read operation may generate small signal perturbations through cross talk, if it is executed while an acquisition is in progress.


Utilities

This section describes supplied programs which may be used to configure various aspects of your instruments:

EEPROM Programming Utility (AcqEEPROMProg)


SFP Command Line Switches

You are here: U1084A User Manual > Utilities > EEPROM Programming Utility (AcqEEPROMProg)

Upgrading your Modules Firmware

The EEPROM programming utility (AcqEepromProg.exe) is used to load either instrument options or firmware to your Agilent instrument.

AcqEpromProg General Information

Syntax:
AcqEepromProg.exe [-eeprom | -maincpld] [sn:<serial>] [efw:<eepromNumber>] [<filename>]

All of the listed switches are optional, please see the notes below for details.

Filename conventions

Files with the ".epr" extension contain instrument options and are generated by Agilent for a specific instrument serial number, they may not be used on instruments with other serial numbers. These files must be loaded to the device Option EEPROM.

Files with the ".vme" or ".svf" extension contain instrument operating firmware generated by Agilent, but may be used on any instrument of the appropriate model type. These files must be loaded into the instrument Firmware EEPROM or CPLD

If one or mores spaces appear in the filename or path, the double quotes are required on the filename string as shown in the examples below.

It is not possible for the utility to check that the file is suitable for the FPGA / CPLD of the specified device, so please use this mode carefully. Programming a device with the incorrect firmware file may render it unusable.
However, as long as the device has not yet been re-booted (power cycled) it will be possible to re-write the correct file. Conversely, if the device has been incorrectly programmed and subsequently re-booted, it will be necessary to return it to an Agilent Service Center for recovery.

Available Switches
Switch | Function
-eeprom | Specifies that the firmware file should be loaded into the device Option EEPROM
-maincpld | Specifies that the firmware should be loaded into the main Firmware EEPROM / CPLD of the instrument
efw:<eepromNumber> | Specifies the Firmware EEPROM number for the firmware to be loaded into. Valid values are '0' or '1'. The value '1' is only supported by the U1084A instrument, and only valid when preceded by -maincpld
sn:<SerialNumber> | Specifies the module to program based on it's serial number. Useful where multiple modules are connected to the host.
Usage examples:
AcqEepromProg.exe

Opens a file dialog box, then loads the content of the chosen file into the EEPROM/CPLD-FPGA of a defined device. If the chosen file has a ".epr" extension, the application will load the file into the Options EEPROM of the device that matches the serial number in the file.

If the chosen file has a ".vme" or ".svf" extension, the application will prompt the user for a target device when there are several devices connected. If there is only one device, that device will be chosen without prompting.

AcqEepromProg.exe <filename>

example:

AcqEepromProg.exe DC271_CH12345.epr

Loads the content of the file 'DC271_CH12345.epr' into the Options EEPROM of the specified device. If there is only one device, that device will be chosen without prompting. When several devices are connected, the application will prompt the user for a target device.

AcqEepromProg.exe -eeprom <filename>

example:

AcqEepromProg.exe -eeprom U1084A_CH12345.epr

Loads the content of the file 'filename' into the Options EEPROM of the specified device. The serial number in the file is used to find the proper target device. The serial number encoded in the options file must match the serial number of the target device.

AcqEepromProg.exe -maincpld <filename>

example:

AcqEepromProg.exe -maincpld "C:\Program Files\IVI Foundation\IVI\Drivers\AgMD1\Firmware\U1084_dig_02380181.vme"

Loads the content of the file 'filename' into the main Firmware EEPROM / CPLD of the specified device. If there is only one device, that device will be chosen without prompting. When several devices are connected, the application will prompt the user for a target device.

AcqEepromProg.exe -maincpld sn:<serial> <filename>

example:

AcqEepromProg.exe -maincpld sn:12345 "C:\Program Files\IVI Foundation\IVI\Drivers\AgMD1\Firmware\m9202_ddc_020000381.vme"

Loads the content of the file 'filename' into the main Firmware EEPROM / CPLD of the specified device.

AcqEepromProg.exe -maincpld dev:<number> -efw:<eepromNumber> <filename>

example:

AcqEepromProg.exe -maincpld dev:1 efw:1 "C:\Program Files\IVI Foundation\IVI\Drivers\AgMD1\Firmware\U1084_dig_02380181.vme"

Loads the content of the file 'filename' into the Firmware EEPROM specified by 'eepromNumber'. The option 'efw' only supports values 0 or 1 and the value 1 is only supported on U1084A instruments.

Requires:
  • QtCore4.dll
  • Qt3Support4.dll
  • QtGui4.dll
  • AgMD1Fundamental.dll
Licensing:

The compiled code used to achieve the 'AcqEepromProg.exe' functionalities are provided in source code from the Lattice 'ispVM(r) Software' package. The use of this compiled source code is subject to conditions, as explained in the section 2.C of the 'Lattice Standard License Agreement.txt' file, which is an integral part of this package.

Copyright (C) 2004, 2005-2012 Agilent Technologies, Inc.


U1092A-HVB XA100 BNC Input Over-voltage Protection

This overvoltage protection kit allows the digitizers with 50 Ohm input (not high-impedance input models) to withstand a high voltage surge of up to 5 kV.

The XA100 overvoltage protection kit contains 2 parts:

  • A 3dB BNC Attenuator
  • A 90 V BNC Spark Gap
Specifications
Parameter | Value
Frequency range | DC to 1 GHz
Input impedance | 50 Ω
Attenuation | 3 dB
VSWR (DC to 1 GHz) | < 1.25
Impulse discharge current (8/20 us pulse) | 10 kA
Weight | 60 g
Length | 85 mm

Both the Spark Gap and the Attenuator MUST be used together in order to fully protect the modules.

In order to limit the input current, the Attenuator MUST be inserted between the Spark Gap and the input of the module.


External Clock (8 bit Digitizers)

External Clock and Reference

For applications where the user wants to replace the internal clock of the digitizer and drive the ADC with an external source, either an External Clock or an External Reference signal can be used.

The Clock or Reference signals can be entered into the digitizer by the dedicated 'CLK IN' MMCX (DC271-FAMILY), MCX (U1071A-Family), or BNC (DC240) connector or via the shared External Input connector on the front panel on other models.

The Clock or Reference signals can be entered into the digitizer via the MCX CK connector on the front panel.

In addition, on certain modelsDC135, DC135HZ, DC140, DC140HZ, DC211, DC211A, DC241, DC241A, DC271, DC271A, DC271AR 1 the PXI Bus 10 MHz system clock signal (PXI_CLK10) can be used as the reference.

External Clock

With External Clock two operating modes are possible; Continuous for the case in which the clock signals are always present and Start/Stop for the situation where the user needs complete control of the sampling process. The Start/Stop mode is not available for the U1071A-Family.

When using a Continuous External Clock, the user must ensure that the input signal has a frequency between 20 MHz and 2 GHz (U1071A-FAMILY and U1061A, U1064A & U1069A) or between 10 MHz and 500 MHz (all other models). For the Start/Stop mode the input signal frequency must be less than 1 GHz (DC271-FAMILY) or 500 MHz (all other models). In all cases it must have a minimum peak to peak amplitude into 50Ω at the digitizer input of at least:

  • 0.5 V for U1061A, U1064A and U1071A Family.
  • 1 V for U1069A.
  • 2 V for other models.

The U1071A-Family has a fixed threshold and uses AC coupling. Otherwise, the transitions of the clock are defined with the aid of a threshold that is user selectable in the range [-2.0 V, 2.0 V]. The signals should not exceed ±5 V amplitude (±1 V a.c. for the U1071A-Family). For a detailed discussion on the programmed use of the external clock, refer to the Programmers Guide - External Clock & Reference Programming section.

The External Clock must be continuously present for use by these digitizers. The input signal must have a frequency between 200 MHz and 2 GHz and a minimum amplitude of at least 0.5 V peak to peak into 50 Ω at the front of the digitizer. The transitions of the clock are defined with the aid of a threshold that is user selectable in the range [-3.0 V to 3.0 V]. The signals should not exceed ±5 V amplitude.

When using a continuous External Clock, the user must ensure that the input signal has a frequency > 100 MHz. The upper limit will depend on the model and can be found in the Programmer’s Guide. The input signal must have minimum amplitude of 1 V peak to peak into 50 Ω at the front of the digitizer. The transitions of the clock are defined with the aid of a threshold that is user selectable in the range [-2.0 V, 2.0 V]. The signals should not exceed ±5 V amplitude. For a detailed discussion on the programmed use of the external clock, refer to the Programmer’s Guide.

When using an External Clock, the user must ensure that the input signal has a frequency of either 1 GHz or 2 GHz and a minimum amplitude of at least 1 V peak-to-peak. The External Clock allows the digitizer to make a voltage measurement when the clock signal passes through a predefined threshold. Normally the external clock sampling rate is the same as the external clock frequency; however for the single-channel mode the sampling rate is twice the clock frequency. The threshold range is variable and user selectable between ± 2 V. The signals should not exceed ±5 V amplitude.

External Reference

For applications that require greater timing precision and long-term stability than is obtainable from the internal clock, a 10 MHz Reference signal can be used. The External Reference is nominally at 10 MHz. However, frequencies in the range shown below may be applied:

  • 9.0 to 10.2 MHz
  • 9.97 to 10.03 MHz for the U1071A
  • 9.0 to 11.0 MHz for the 12-bit-FAMILY

If you do use a frequency other than 10.0 MHz, you may need to correct for the difference in your application since the digitizer and the driver have no way to know about such deviations.

The amplitude and threshold conditions, for an External Reference, are the same as for the External Clock.

If synchronization between several digitizers is required, the reference signal should be applied to all of them.

A square wave with better than 5 ns risetime should be used. This is needed to avoid false or multiple transitions on a slower risetime signal. Alternatively, a >2 V amplitude signal could be used.

When using this capability please make sure that the module is correctly synchronized on the signal. This might require adjusting the threshold. If this is not the case the data will be useless and calibration can fail in rather obscure ways.


Trigger

Normally the trigger settings applied to the digitizer are used to determine the time at which the device will stop acquiring data. Some models are also capable of a ‘Start on Trigger’ mode of acquisition. The various trigger settings are outlined below.

Trigger Source

The trigger source can be a signal applied to either an Input Channel (internal triggering) or the External Trigger Input.

Trigger Coupling

Trigger coupling is used to select the coupling mode applied to the input of the trigger circuitry. Modes available include AC LF Reject and DC. The AC LF Reject mode couples signals capacitively and removes the input signal's DC component and signals below 50 KHz. DC mode allows all signal components to be passed through to the trigger circuit.

Trigger Level

The trigger level specifies the voltage at which the selected trigger source will produce a valid trigger. The trigger level is defined as a set voltage. Using the internal trigger, the level is set with respect to the midpoint voltage (Vm= – Offset voltage) of the digitizer’s vertical scale. Internal trigger level settings (expressed in %) must be within Vm ± 0.6 FS, where FS is the channel Full Scale. All trigger circuits have sensitivity levels that must be exceeded in order for reliable triggering to occur.

The external trigger of the U1084A can be set in the range ± 5 V.

Edge Trigger Slope

The trigger slope defines which one of the two possible transitions will be used to initiate the trigger when it passes through the specified trigger level. Positive slope indicates that the signal is transitioning from a lower voltage to a higher voltage. Negative slope indicates the signal is transitioning from a higher voltage to a lower voltage.

Window Trigger

The U1061A, U1064A & U1069A digitizers and the 2 channels of the U1071A-FAMILY implement a Window trigger. Two trigger level thresholds are used to define the desired range. The trigger can then be chosen to occur either when the signal exits or enters the window range. This mode can be thought of as the appropriate OR of two edge triggers of opposite slope.

Pre- and Post-Trigger Delay

To increase trigger flexibility a pre- or post-trigger delay can be applied to the trigger position.

The amount of pre-trigger delay can be adjusted between 0 and 100% of the acquisition time window (i.e. sampling interval x number of samples), whereas the post-trigger delay can be adjusted between 0 and 200 million samples. The U1071A-FAMILY allows a post trigger delay of up to 234 - 1 samples.

Pre- or post-trigger delays are just different aspects of the same trigger positioning parameter:

  • The condition of 100% pre-trigger indicates that all data points are acquired prior to the trigger, i.e. the trigger point is at the end of the acquired waveform.
  • The condition of 0% pre-trigger (which is identical to a post-trigger of 0) indicates that all data points are acquired immediately after the trigger, i.e. the trigger point is at the beginning of the acquired waveform.
  • The condition of a non-zero post-trigger delay indicates that the data points are acquired after the trigger occurs, at a time that corresponds to the post-trigger delay, i.e. the trigger point is before the acquired waveform.

The digitizer hardware accepts pre- and post-trigger adjustments in increments of 16 samples. By definition post-trigger settings are a positive number and pre-trigger settings are a negative number.

Thus it is only natural that the software drivers treat pre- and post-trigger delays as a single parameter in seconds that can vary between –nbrSamples * samplingInterval (100% pre-trigger) and +maxPostTrigSamples * samplingInterval (max post-trigger). Since the Agilent software drivers provide very accurate trigger position information upon waveform readout, the accepted resolution of the user-requested pre-/post-trigger delay is much better than 16 samples. For more details, please refer to the Programmers Guide (U1092-90003).

Trigger Time Calibration

The trigger position is dynamically calibrated each time the sample rate changes from 4GS/s to 2GS/s or less, or back to 4GS/s when the module is configured as a single channel module.

The trigger position is also dynamically calibrated each time the sample rate changes from 2GS/s to 1GS/s or less, or back to 2GS/s when the module is configured as a single channel module.

Trigger Status

The front panel includes a tri-color LED indicator to show the status of the trigger. When the LED is green it indicates the trigger is armed and waiting for a valid trigger to occur. Red indicates that the trigger has occurred, the acquisition is complete and the data is waiting to be readout.